[Map] Welcome screen strings not localized for Here map

RESOLVED FIXED

Status

Tech Evangelism
Preinstalled B2G Apps
RESOLVED FIXED
5 years ago
4 years ago

People

(Reporter: Leo, Unassigned)

Tracking

(Blocks: 1 bug, {regression})

Trunk
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(blocking-b2g:leo+)

Details

(Whiteboard: [TD-29870][3rd Party][TD-75248][POVB])

Attachments

(4 attachments)

(Reporter)

Description

5 years ago
STR:
1. Open Here Map
2. Displays the welcome screen with privacy agreement and description

Expected:
1. Locale should be applied to the welcome screen

Actual:
1. The strings will be displayed only in english
(Reporter)

Updated

5 years ago
Summary: [Map] Welcome screen sting not localized for Here map → [Map] Welcome screen strings not localized for Here map
(Reporter)

Comment 1

5 years ago
Please let know know the possibilities of string localization for external application.
blocking-b2g: --- → leo?
Flags: needinfo?(jsmith)

Updated

5 years ago
blocking-b2g: leo? → ---
Component: General → Preinstalled B2G Apps
Flags: needinfo?(jsmith)
Product: Boot2Gecko → Tech Evangelism
(Reporter)

Updated

5 years ago
Whiteboard: [TD-29870]
(In reply to Leo from comment #1)
> Please let know know the possibilities of string localization for external
> application.

Nokia manages this. Business development is meeting with them tomorrow, so as long as I link up the bug as such, they'll see this bug.
Blocks: 837298
(Reporter)

Comment 3

5 years ago
Is there any update, if this will be considered. If so, when we could expect to see this on device.
Flags: needinfo?(jsmith)
Don't know. But one of the Nokia team members who built the app would know.
Flags: needinfo?(jsmith) → needinfo?(pawel.wojciechowski)

Comment 5

5 years ago
The latest version of the HERE Maps from Marketplace (v1.8.58) is localized into 3 languages: English, Spanish and Brazilian Portuguese. Currently we are working on Polish translations. Welcome screen is also localized into these languages. There is one specific case when HERE Maps is not localized and more details about this issue you can find here: https://bugzilla.mozilla.org/show_bug.cgi?id=830774#c9.
Flags: needinfo?(pawel.wojciechowski)
(Reporter)

Comment 6

5 years ago
The current version of Here map present in Gaia is v1.8.44. As i know, we cannot install the new version from marketplace as long as the application is present as pre-installed. The only way will to be update the application.

Do you have any idea if this latest version will be made part of gaia or if an update will be provided.
Flags: needinfo?(jsmith)
(In reply to Leo from comment #6)
> The current version of Here map present in Gaia is v1.8.44. As i know, we
> cannot install the new version from marketplace as long as the application
> is present as pre-installed. The only way will to be update the application.
> 
> Do you have any idea if this latest version will be made part of gaia or if
> an update will be provided.

There's a separate bug pulling the maps app out of the repository soon. After that lands, we'll do updates of the app as part of customizations.

Given however this was fixed and submitted to marketplace, I'll close this bug.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Flags: needinfo?(jsmith)
Resolution: --- → FIXED
(Reporter)

Updated

5 years ago
Whiteboard: [TD-29870] → [TD-29870], [3rd Party]
(Reporter)

Comment 8

5 years ago
Created attachment 778269 [details]
Welcome screen in pt-BR

Now the welcome screen is localized
(Reporter)

Comment 9

5 years ago
Created attachment 778278 [details]
privacy disclaimer page for nokia in English

Jason, with the latest application, the welcome screen is localized to pt-BR, but the links like "More information about privacy", "Privacy policy", "Terms of use" in the welcome screen opens in browser and are not localized to pt-BR. Please confirm if these pages will be localized from nokia.
Flags: needinfo?(jsmith)
(Reporter)

Updated

5 years ago
Flags: needinfo?(pawel.wojciechowski)
The other person you have needinfoed is probably a better person to answer that question.
Flags: needinfo?(jsmith)

Comment 11

4 years ago
Leo keeps tracking this issue becauese our quality team is thinking that it is very important to end users. Please update the current status.
(Reporter)

Comment 12

4 years ago
Reopening. Please give comment for comment 9 and change status if required.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Comment 13

4 years ago
The issue with not localized external pages (e.g. "More information about privacy", "Privacy policy", "Terms of use") should be solved within 3-4 weeks. Is that fine with you?
Flags: needinfo?(pawel.wojciechowski)
(Reporter)

Comment 14

4 years ago
Created attachment 787984 [details]
Non localized strings for Here maps

I have tested on the latest available version v1.8.69 with portuguese language and found that the strings are not localized. This was not reproduced a little old version and look like there is some kind of regression. I tried changing the language inside the application and all the strings are localized.
But the welcome screen cannot be localized by changing the language inside the app. so at a bare minimum, the welcome screen should be localized.
Flags: needinfo?(pawel.wojciechowski)
(Reporter)

Comment 15

4 years ago
Can you confirm this is not due to regression Leo.
Flags: needinfo?(jsmith)
Whiteboard: [TD-29870], [3rd Party] → [TD-29870], [3rd Party][TD-75248]
(Reporter)

Updated

4 years ago
Blocks: 903331
(In reply to Leo from comment #15)
> Can you confirm this is not due to regression Leo.

It shouldn't be. All of this is controlled by the app developer, so I would be surprised if this was a gecko/gaia issue.
Flags: needinfo?(jsmith)

Comment 17

4 years ago
We're looking into it.

Leo
Flags: needinfo?(pawel.wojciechowski)

Comment 18

4 years ago
We should differentiate two use cases. 
1) the very first time you open the app. We've just tested with 1.8.69 and it always takes the system's locale to set the language;
2) The user's opened the app and left it to change the language in the system (https://bugzilla.mozilla.org/show_bug.cgi?id=828337). The current behavior: the app ignores the new setting. The fix for it is supposed to go live inside the next two weeks. As we have a ticket id=828337 for this issue can we close this one?

If it's the 1 use case please let us know the steps to reproduce the issue and device/system details.

The environment we've tested with:
HERE Maps 1.8.69
FxOS: OS version 1.1.0.0-prerelase
      Platform version 18.1
      Update channgel unagi/1.1.0/beta
      Git commit info 2013-07-08 10:15:37
Device: Unagi


Leo
Flags: needinfo?(leo.bugzilla.gaia)
(Reporter)

Comment 19

4 years ago
(In reply to ZieL from comment #18)
> We should differentiate two use cases. 
> 1) the very first time you open the app. We've just tested with 1.8.69 and
> it always takes the system's locale to set the language;
This is where i am having problem. The app is not detecting the system language during first start up.

STR:
  1. Flash a new binary on the phone and select language as "Portuguese" during 
     start up.
  2. Now open "Here Maps" and check the language in which "Welcome screen" is 
     displayed.

The welcome screen is always displayed in English. This was tested for both Spanish and Portuguese.


> 2) The user's opened the app and left it to change the language in the
> system (https://bugzilla.mozilla.org/show_bug.cgi?id=828337). The current
> behavior: the app ignores the new setting. The fix for it is supposed to go
> live inside the next two weeks. As we have a ticket id=828337 for this issue
> can we close this one?
I am not particularly worried about app not detecting the system language during runtime as a restart of the app will do it. Here we could wait for bug 828337 to go live.

Details on Test Environment:
HERE Maps 1.8.69
FxOS: OS version: 1.1.0.0-prerelease
      Platform version: 18.1
      Update channel: nightly
      Git commit info: 2013-08-02 02:05:43
      build ID: 20130802112417
Device: leo

Hope these details are helpful!
Jason, could you help in reproducing this?
Flags: needinfo?(ziel.leo)
Flags: needinfo?(leo.bugzilla.gaia)
Flags: needinfo?(jsmith)
Jeni - Can you try reproducing this bug per Leo's request?
Flags: needinfo?(jsmith) → needinfo?(jcouassi)

Comment 21

4 years ago
Issue does repro... Here Maps version: 1.8.69
Repro Steps:
1. Flash device to new base build v08o
2. Select 'Portuguese' as FTU
3. Select 'Here Maps' 
4. View what is listed

The 'Welcome screen' is not localized it is displayed in English only
Note: More information about privacy, Privacy policy and Terms of Use are not localized as well

Build ID: 20130802164042
Gecko: /rev/
Gaia: 402e0921f78e5e93bbffb7c67c6b32164df14692
Platform Version: 18.1
Flags: needinfo?(jcouassi)

Comment 22

4 years ago
Just to make sure I've got it tight. Te whole app is not localized and not only the welcome page, right?

It looks to me that it's somehow a regression on gecko/gaia side.
It's very simple. The version 1.8.69 which is now in the market place was pushed on 2013-07-08 and positively tested in the comment 8 from 2013-07-18. Now the same untouched version appears to have a regression with the latest firmware. To be hones it doesn't look to me it's a regression in the app. 

We're creating a simple packaged app which should only contain the logic for choosing the proper language based on the system settings. The same logic we have in HERE Maps. Once it's done we'll attach it here. And you can test on your end. It allows you to check our logic which can be wrong and at the same time we can check the system.


Br,
Leo
Flags: needinfo?(ziel.leo)
(Reporter)

Comment 23

4 years ago
(In reply to ZieL from comment #22)
> Just to make sure I've got it tight. Te whole app is not localized and not
> only the welcome page, right?
Yes.
> It looks to me that it's somehow a regression on gecko/gaia side.
> It's very simple. The version 1.8.69 which is now in the market place was
> pushed on 2013-07-08 and positively tested in the comment 8 from 2013-07-18.
> Now the same untouched version appears to have a regression with the latest
> firmware. To be hones it doesn't look to me it's a regression in the app. 
> 
> We're creating a simple packaged app which should only contain the logic for
> choosing the proper language based on the system settings. The same logic we
> have in HERE Maps. Once it's done we'll attach it here. And you can test on
> your end. It allows you to check our logic which can be wrong and at the
> same time we can check the system.
> 
> 
> Br,
> Leo
Your comments make sense.

Jason, can we have an investigation here to find where the regression occurred.
Flags: needinfo?(jsmith)

Comment 24

4 years ago
Created attachment 789513 [details]
Test app for localization

As discussed, here is the application to test the localization issue.
Please let us know the results of the test.
Okay. Putting regressionwindow-wanted then for someone to get a regression window. Noming for leo then as well since is 1.1 regression that causes localization of maps to be broken during first use.
blocking-b2g: --- → leo?
Component: Preinstalled B2G Apps → General
Flags: needinfo?(jsmith)
Keywords: regression, regressionwindow-wanted
Product: Tech Evangelism → Boot2Gecko

Updated

4 years ago
No longer blocks: 837298
Please assign to whichever bug is identified as the regression.
blocking-b2g: leo? → leo+

Updated

4 years ago
QA Contact: dwatson

Comment 27

4 years ago
After doing some researching it looks like between V08m and V08o something happened. The issue is seen on V08o, but not on V08m. On V08m the correct "Welcome" screen is displayed. 

After looking through some of the files it looks like the update.manifest changed between the two builds. Also it looks like both builds have the same version of the HERE Maps app, according to the version.txt file.

V08o
Build ID: 20130802164042
Gecko: /rev/
Gaia: 402e0921f78e5e93bbffb7c67c6b32164df14692

V08m
Build ID: 20130721095109
Gecko: /rev/
Gaia: 47872e74e310a8b575ab39f1a9f334e229be995c
Can you get a regression range also with the installed HERE Maps on a non-partner build? That would help narrow this down to a day.

Comment 29

4 years ago
After installing the HERE maps app through the marketplace app, the Welcome screen displayed in Portuguese.

Issue did not reproduce on - 
Base Image: V08o
Build ID: 20130802071207
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/ba71c64705e5
Gaia: 361cfb69e22c0db18e85422bb407550426138009
Platform Version: 18.1
RIL Version: 01.01.00.019.180

Build ID: 20130721070210
Base Image: V08o
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/1dffc79bfac5
Gaia: c4bdd3210864938b8ffd252c442ddcd442d09944
Platform Version: 18.1
RIL Version: 01.01.00.019.164 

Build ID: 20130820041204
Base Image: V08o
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/bc2c6813842e
Gaia: 849cee8a3ee5a2a6f4e39183549d36c3acc05f2f
Platform Version: 18.1
RIL Version: 01.01.00.019.197
Ah, I know one potential problem here. The Leo build is running an out of date HERE Maps preinstalled on the device.

Version preinstalled on device = 1.8.69

Version on marketplace = 1.8.73

Leo needs to update the HERE Maps they have preinstalled on the device.

However - if this is only reproducing on a partner image, that makes this a POVB issue on Leo's side.
Keywords: regressionwindow-wanted
Whiteboard: [TD-29870], [3rd Party][TD-75248] → [TD-29870][3rd Party][TD-75248][POVB]

Updated

4 years ago
Component: General → Gaia
(Reporter)

Updated

4 years ago
Blocks: 903330
(Reporter)

Comment 31

4 years ago
(In reply to Darren from comment #29)
> After installing the HERE maps app through the marketplace app, the Welcome
> screen displayed in Portuguese.
> 
> Issue did not reproduce on - 
> Base Image: V08o
> Build ID: 20130802071207
> Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/ba71c64705e5
> Gaia: 361cfb69e22c0db18e85422bb407550426138009
> Platform Version: 18.1
> RIL Version: 01.01.00.019.180
> 
> Build ID: 20130721070210
> Base Image: V08o
> Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/1dffc79bfac5
> Gaia: c4bdd3210864938b8ffd252c442ddcd442d09944
> Platform Version: 18.1
> RIL Version: 01.01.00.019.164 
> 
> Build ID: 20130820041204
> Base Image: V08o
> Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/bc2c6813842e
> Gaia: 849cee8a3ee5a2a6f4e39183549d36c3acc05f2f
> Platform Version: 18.1
> RIL Version: 01.01.00.019.197

Is this tested on Leo device? How did you install the new application from Marketplace?
I tried updating the Map to version 1.8.73, but am still reproducing the issue.
Flags: needinfo?(jsmith)
Flags: needinfo?(dwatson)
(In reply to Leo from comment #31)
> (In reply to Darren from comment #29)
> > After installing the HERE maps app through the marketplace app, the Welcome
> > screen displayed in Portuguese.
> > 
> > Issue did not reproduce on - 
> > Base Image: V08o
> > Build ID: 20130802071207
> > Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/ba71c64705e5
> > Gaia: 361cfb69e22c0db18e85422bb407550426138009
> > Platform Version: 18.1
> > RIL Version: 01.01.00.019.180
> > 
> > Build ID: 20130721070210
> > Base Image: V08o
> > Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/1dffc79bfac5
> > Gaia: c4bdd3210864938b8ffd252c442ddcd442d09944
> > Platform Version: 18.1
> > RIL Version: 01.01.00.019.164 
> > 
> > Build ID: 20130820041204
> > Base Image: V08o
> > Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/bc2c6813842e
> > Gaia: 849cee8a3ee5a2a6f4e39183549d36c3acc05f2f
> > Platform Version: 18.1
> > RIL Version: 01.01.00.019.197
> 
> Is this tested on Leo device? How did you install the new application from
> Marketplace?
> I tried updating the Map to version 1.8.73, but am still reproducing the
> issue.

The testing done there was done on a Com RIL build with Leo. It was installed by going to marketplace.firefox.com and installing HERE Maps.

I think what has been found here is that the regression appears to be in leo partner builds only - not generally.
Flags: needinfo?(jsmith)
(Reporter)

Comment 33

4 years ago
could you share the manifest.webapp URL from marketplace. I will try upgrading the application using that.
Flags: needinfo?(dwatson) → needinfo?(jsmith)
(In reply to Leo from comment #33)
> could you share the manifest.webapp URL from marketplace. I will try
> upgrading the application using that.

https://marketplace.firefox.com/app/here-maps-packaged is the marketplace URL.

Manifest URL = https://marketplace.firefox.com/app/7eccfd71-2765-458d-983f-078580b46a11/manifest.webapp.
Flags: needinfo?(jsmith)
(Reporter)

Comment 35

4 years ago
We did some debugging of the Here Maps. Our observations here are:

The below code is the one used in the application for detecting the language
>>return (l || b.match(/\w{2}-\w{2}/) && RegExp.lastMatch || a.language || a.browserLanguage).toLowerCase()

Here the second logic "b.match(/\w{2}-\w{2}/) && RegExp.lastMatch" used for detecting the language is a faulty one. In this, they are checking the UA-String to get a match for a string having two characters followed by '-' and then followed by two characters eg: xx-xx.

The UA-String used in leo device is "Mozilla/5.0 (Mobile; NN-NNNN; rv:18.1) Gecko/18.1 Firefox/18.1". Here the above case will end up detecting the device language as "NN-NN".
As per this reference https://hacks.mozilla.org/2010/09/final-user-agent-string-for-firefox-4/, locale need not be the part of UA-String. So this logic of checking the UA-String for detecting the locale is not a good one and at times like this, will end up in issues like these.

So here, we should either get rid of this logic or should not rely on it as a primary choice or make a more stricter pattern matching.
Flags: needinfo?(ziel.leo)
Flags: needinfo?(diego.arteaga-posada)

Updated

4 years ago
Component: Gaia → Preinstalled B2G Apps
Product: Boot2Gecko → Tech Evangelism
Version: unspecified → Trunk

Updated

4 years ago
Blocks: 837298
(Reporter)

Comment 36

4 years ago
Any update here! Can we have an acknowledgement if this was notified with developer?

Comment 37

4 years ago
Hello,

As proposed, we're going to change the order of the check so that the user agent will be just a fallback. As we don't have any leo device to try the fix on can we send a new package to Donovan or Jason to give a try on a real device before pushing to the market place? 

Br,
Leo
Flags: needinfo?(ziel.leo)
Flags: needinfo?(diego.arteaga-posada)
(In reply to ZieL from comment #37)
> Hello,
> 
> As proposed, we're going to change the order of the check so that the user
> agent will be just a fallback. As we don't have any leo device to try the
> fix on can we send a new package to Donovan or Jason to give a try on a real
> device before pushing to the market place? 
> 
> Br,
> Leo

I'm confused. The signature says you are leo but you don't have a leo device to test. Why can't you test this?
Testing on unagi should be fine, just test there and push to the marketplace if it works.
(In reply to Donovan Preston from comment #39)
> Testing on unagi should be fine, just test there and push to the marketplace
> if it works.

Don't think so. Unagi doesn't have the device info in the UA that leo has.
Hmm, you're right. In that case, yes, send me a package with the updated code and I will test on Leo.

Comment 42

4 years ago
(In reply to Leo from comment #36)
> Any update here! Can we have an acknowledgement if this was notified with
> developer?

(In reply to Donovan Preston from comment #39)
> Testing on unagi should be fine, just test there and push to the marketplace
> if it works.

Yes, Mozilla Partner Engineering team has been in contact with Nokia on this bug.

Comment 43

4 years ago
@jason  No all leos have a leo device  :-) My name is Leonid or shortly Leo. Sorry for any confusion.

@donovan and @karen: I've just sent a package I mentioned above to Donovan. Donovan, please let us know if we can update the package in the market place.

Thx,
Leo without a leo device :-)
Thanks Leonid ;-) I got the package and will test.
Ok Leonid, I tested the package you sent me and the welcome screen is correctly displayed in the language chosen in the Settings app. Go ahead and submit to the marketplace.

Thanks.

Comment 46

4 years ago
Thanks, Donovan. The app is submitted and already approved. The new version is 1.8.77.

Br,
Leo
(Reporter)

Comment 47

4 years ago
I have tested latest version 1.8.77 on leo device and it works fine.
Thanks for the effort here Leonid.
Status: REOPENED → RESOLVED
Last Resolved: 5 years ago4 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.