[Settings][USB Storage] UX design issue of USB storage enabling

RESOLVED INVALID

Status

Firefox OS
Gaia::Settings
RESOLVED INVALID
5 years ago
4 years ago

People

(Reporter: ypwalter, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

159.15 KB, application/pdf
Details
(Reporter)

Description

5 years ago
Using Unagi pvt v1train&master build for testing.

Steps:
 1. Go to "Settings" app
 2. Go to area of "Storage"
 3. enable USB sorage

You will find it strange:
  a. you enabled it, but the pc doesn't show up with any usb storage
  b. you need to go into "Media storage" section and enable "share using USB"

Here is the suggestion for this:

Original design before enabling USB storage:

     ****Storage**************
     -------------------------
     |Enable USB storage [O ]|
     -------------------------
     |Application storage    |
     -------------------------
     |Media storage          |
     -------------------------

Original design after enabled USB storage:

     ****Storage**************
     -------------------------
     |Enable USB storage [VO]|
     -------------------------
     |Application storage    |
     -------------------------
     |Media storage          |
     -------------------------


Proposed UX design for "after enabled USB storage"
     ****Storage**************
     -------------------------
     |Enable USB storage [VO]|
     -------------------------
     | Internal Storage  [O ]|  <-default storage or all choices
     -------------------------    should pop up here for further
     |Application storage    |    selection.
     -------------------------
     |Media storage          |
     -------------------------

This should be something like "Bluetooth" section in "Settings" app. After you enabled bluetooth, you should see some further information to show up, like "Visible to all".

I think we could have "Internal Storage" and "Memory Card" choices pop up after enabled USB storage. Otherwise, we can pop up the most frequently used choice or default choice, might be "Internal Storage".


It make no sense to enable it in settings app main section and still go into "Media storage" section for enabling it again.
(Reporter)

Updated

5 years ago
Flags: needinfo?(firefoxos-ux-bugzilla)
Summary: [Settings][USB Storage] UX design issue of USB storage → [Settings][USB Storage] UX design issue of USB storage enabling
(Reporter)

Comment 1

5 years ago
Also, I have a question about "Enable USB storage":

Enable USB Storage  internal storage
                     Share using USB
-------------------------------------
    Enabled              Disabled       -> nothing happens
    Disabled             Enabled        -> internal storage shared
    Enabled              Enabled        -> internal storage shared
    Disabled             Disabled       -> nothing happens

In this case, I can recognize the role of "Enable USB Storage" option. Can you explain the UX design of this? Is there any UX mock-up, spec, or user stories?

Comment 2

5 years ago
Created attachment 751800 [details]
Storage proposal

Updated

5 years ago
Flags: needinfo?(firefoxos-ux-bugzilla)

Comment 3

5 years ago
Hi there,
I've attached a storage proposal for review.  Please let me know what you think!
Duplicate of this bug: 869370
(Reporter)

Comment 5

5 years ago
Hi, I do have a question about this.

In this proposal, it states default action after enabling the storage is to share SD card. (1) Is it default to do so? Do we still need to go in "Media storage" section to enable either device internal memory or memory card? If not, then it should be fine. If we need to do so, the enabling outside in settings app main section would be redundant.  (2)Maybe there should be some way to give notification to users that they can change the enabling of device inside "Media storage" section? Otherwise, thinking of a way to enabling it in main section of Settings app would be more user-friendly.
What Walter asked is basically my concern in bug 869370.

Based on the proposal, if users want to enable USB storage, they need to turn on two switches: (1) Turn on the "Enable USB storage" switch in the main section or the media storage section. (2) Enter the media section and turn on the "Share using USB" switch.

Users may get confused if they only turn on the first switch and don't see the storage listed on their computer.

Updated

5 years ago
Flags: needinfo?(kyee)
Duplicate of this bug: 875698
(Reporter)

Updated

5 years ago
Flags: needinfo?(kyee)
(In reply to Arthur Chen [:arthurcc] from comment #6)
> What Walter asked is basically my concern in bug 869370.
> 
> Based on the proposal, if users want to enable USB storage, they need to
> turn on two switches: (1) Turn on the "Enable USB storage" switch in the
> main section or the media storage section. (2) Enter the media section and
> turn on the "Share using USB" switch.
> 
> Users may get confused if they only turn on the first switch and don't see
> the storage listed on their computer.

So it's also useful to be aware that the 2 switches are different. On is a master switch and one is a per-volume switch.

The per-volume switch is needed when there are multiple volumes (currently only the leo device has multiple volumes).

If there is only a single volume, then it may make sense to have the per-volume switch track the master switch.

If there are multiple volumes, and none are enabled, then turning on the master switch should probably do something like show additional items, or present a dialog.
I also think that it would reasonable to make the "Share using USB" option be enabled by default for the volume corresponding to sdcard (On some phones (like leo) this will be called "Internal Storage" and on some phones (like unagi) this will be called "SD Card Storage").

Then, at least when you "Enable USB storage" you'll have a reasonable default behaviour.
I just landed bug 876055, which sets "Share using USB" be on by default for sdcard and off by default for extsdcard.

This will at least give a reasonable experience when chossing "Enable USB Storage".
Thanks, Dave. Making at least one volume enabled by default makes much more senses to me.

Comment 12

5 years ago
Yup, Dave's got this one right.   I will think about making changes to some of the wording to make it more clear.
Flags: needinfo?(kyee)
It's pretty ridiculous that we have three buttons that say pretty much the same thing that all have to be turned on to share via USB on my computer. Was coming close to filing an upset bug report (after wasting 30 minutes trying to figure this out) when I found this. Forgive the rant.
(Reporter)

Comment 14

5 years ago
What's the status of this one? any news?
(In reply to Walter Chen[:ypwalter][:wachen] from comment #14)
> What's the status of this one? any news?

Hey Walter,
The UX and API changed a lot since then. Could you please verify it again? If you still think it's a problem, please ni UX for a better idea to move this bug forward. Otherwise, close this bug as invalid or worksforme. Thanks!
Flags: needinfo?(wachen)
(Reporter)

Comment 16

4 years ago
I just checked it. I think it is fine as for now. close as invalid.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Flags: needinfo?(wachen)
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.