default action for filetype should default to windows file associations

RESOLVED WORKSFORME

Status

()

Core
Networking
RESOLVED WORKSFORME
17 years ago
4 years ago

People

(Reporter: hans_k_97, Assigned: Scott MacGregor)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
When downloading a link that mozilla can't handle internally, the
default-action-for-filetype currently needs to be set up manually for each new
filetype.
it should check the default OS file associations first and set that if possible-
there are a lot of filetypes out there and it's frustrating to have to
re-associate each new type every time.

Comment 1

17 years ago
Dup of bug 54940?
er... we _should_ be checking the OS associations, based on the code I see.  Is
that going wrong somehow?

Over to mscott
Assignee: neeti → mscott
(Assignee)

Comment 3

17 years ago
For me, it's using the information from the windows registry to launch the right
app. This is working using build ID: 2001062104. Just select "use default
action" and it launches acrobat for pdf files, winzip for zip files etc. Based
on my registry settings. No user intervention required.

Comment 4

17 years ago
1. The effect seen by the reporter is probably caused partly by
bug 46655 ("Downloading" dialog displays incorrect MIME type) and by bug 78943
(MIME type reported incorrectly for certain file extensions), which confuse
users into thinking that mozilla doesn't use the OS's mime type helper app list.

2. It would really be nice for bug 54940 to be fixed but it is not nessasary for
this bug.

3. bug 86640 (Redesign the helper app dialog) should make the current behavior
more usable and (maybe fix this bug too?).

4. To implement the feature based on the author's description would require
extension matching rather than mime type matching, which I doubt is a good idea.
Having said that, the helper app dialog should suggest helper app based on file
extensions when encountering a new mime type.
For example, if I associated:
mime-type: application/x-zip-compressed
extension: .zip
with freezip.exe in windows "file type" dialog.

and Mozilla encounters
mime-type: application/zip
extention: .zip
it should suggest that I create a new helper app entry for the new mime type and
associated with freezip.exe

Comment 5

17 years ago
This WORKSFORME I am marking as such.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 6

17 years ago
Hmm.  Ok, the actual bug is apparently more of a usability problem.

It's not really clear what the default action is unless you fill in the default
action inside mozilla.  I was assuming that the blank textbox underneath the
"use default action" button meant that there was no default action (instead of
"blank = use win98 file associations").  and there's enough mime types out there
that it's a non-zero load to remember exactly which types you've selected what
action for.

So it would be useful to include the current system file-action association if
possible, but I'm not experiencing any functionality problems now that I know
how to use it. 
(Assignee)

Comment 7

17 years ago
please try a more recent build. we redesigned this dialog to better show the OS
default helper app.
(Reporter)

Comment 8

17 years ago
Definitely better.  Most usable would be text in the Default Action box that
says [Using default system action for filetype] or the like.  The usability
issue is that the blank box is distracting (and the new text changes are much
better but still small), so that would help some.

Also, is there any way to make "download" the default action?  Avoiding extra
clicks is always a big win.

My original issues have been resolved, though- I don't think these are important
enough to open new bugs on?
> Also, is there any way to make "download" the default action?  Avoiding extra
> clicks is always a big win.

See bug 80557 and bug 86640

Comment 10

17 years ago
reporter:

This bug is a "futured" or "untargeted" bug which has been "resolved/works for
me". Most bugs meeting this criteria are usually somewhat out of date or working
in the current builds.

If this bug is not happening for you in a recent build (such as the Mozilla
daily build, Mozilla 0.9.3, or Netscape 6.1), please use the friendly "Mark bugs
as VERIFIED" radio button to set this bug to "VERIFIED/WORKS FOR ME"
If you reported the bug on a platform (e.g. Linux) and other contributors
reported on another platform (e.g. Mac OS), please comment that it works for you
 but do not verify it yet.

For these multi-platform bug reports, we need to verify all reported platforms
-OR- create new "still broken on platform X" bugs when you verify.
You need to log in before you can comment on or make changes to this bug.