(Australis) OS X Tab label needs vertical adjustments

RESOLVED FIXED in Firefox 28

Status

()

defect
RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: morpheus3k+bugzilla, Assigned: MattN)

Tracking

Trunk
Firefox 28
All
macOS
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [Australis:M7], )

Attachments

(2 attachments)

Reporter

Description

6 years ago
Posted image Tab label difference
The design specs of Australis shows that the tab label and the close button are vertical aligned. In the currenct UX build the text a few pixel down.

I've attached a screenshot for comparison.
Reporter

Updated

6 years ago
Whiteboard: [Australis:M?]
I thought I got this right in bug 826689 by overlaying the mockup on my screenshot but I believe that's because I used the live mockup as the reference and it differs from the image mockup.
Stephen, which mockup is correct? If the image is correct, extra bonus points for fixing the live mockup :)
Flags: needinfo?(shorlander)
Hardware: x86 → All
Reporter

Comment 2

6 years ago
I've seen in the meeting notes a link to a recent design spec:

http://people.mozilla.com/~shorlander/files/australis-design-specs/australis-design-specs-osx.html

Maybe this helps.
(In reply to Matthew N. [:MattN] from comment #1)
> I thought I got this right in bug 826689 by overlaying the mockup on my
> screenshot but I believe that's because I used the live mockup as the
> reference and it differs from the image mockup.
> Stephen, which mockup is correct? If the image is correct, extra bonus
> points for fixing the live mockup :)

Unfortunately getting Photoshop text to line up exactly with platform text is not exact :)

If we move it up 1px on UX it should be about right.
Flags: needinfo?(shorlander)
Okie doke
Assignee: nobody → mnoorenberghe+bmo
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Whiteboard: [Australis:M?] → [Australis:M7]
Despite the fact that the margin value is changing by 2px, it's only visually shifting by 1px.
Attachment #763178 - Flags: review?(shorlander)
Comment on attachment 763178 [details] [diff] [review]
v.1 Move tab label up 1px

Review of attachment 763178 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good to me. Thanks!
Attachment #763178 - Flags: review?(shorlander) → review+
Removing the items from M7 that do not block landing on m-c.
Whiteboard: [Australis:M7] → [Australis:M?]
https://hg.mozilla.org/projects/ux/rev/826dde975a68

Thanks
Whiteboard: [Australis:M?] → [Australis:M7][fixed-in-ux]

Comment 9

6 years ago
https://hg.mozilla.org/mozilla-central/rev/826dde975a68
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Whiteboard: [Australis:M7][fixed-in-ux] → [Australis:M7]
Target Milestone: --- → Firefox 28
You need to log in before you can comment on or make changes to this bug.