(Follow up) Remove single elements in the call log is not possible (delete all, works)

RESOLVED FIXED

Status

RESOLVED FIXED
6 years ago
5 years ago

People

(Reporter: alberto.pastor, Unassigned)

Tracking

unspecified
x86
Mac OS X
Bug Flags:
in-moztrap +

Firefox Tracking Flags

(blocking-b2g:leo+, b2g18 fixed)

Details

(URL)

Attachments

(1 attachment)

355 bytes, text/html
gtorodelvalle
: review+
Details
(Reporter)

Description

6 years ago
Follow up of Bug 847406

STR:

1.- Install gaia master
2.- Open the dialer
3.- Go to call log
4.- Enter edit mode and click one 1 call
5.- Delete
6.- Reopen the dialer

Expected

The call is not there anymore

Actual

After restarting, the call is still ther
(Reporter)

Updated

6 years ago
Depends on: 847406
(Reporter)

Comment 1

6 years ago
Created attachment 751030 [details]
Pointer to PR 9848
Attachment #751030 - Flags: review?(etienne)
Comment on attachment 751030 [details]
Pointer to PR 9848

Can't look in details why right now, but this patch wasn't working for me (commented on github with details).

Monday is a bank holiday in France, feel free to ask German for review to speed this up since I won't be able to look at it again before tuesday.
Attachment #751030 - Flags: review?(etienne)
(Reporter)

Updated

6 years ago
Attachment #751030 - Flags: review?(gtorodelvalle)
Comment on attachment 751030 [details]
Pointer to PR 9848

Hi guys! Looks good and working to me ;-) Thank you very much, Alberto! Once Travis is ready, I'd say we are good to go!
Attachment #751030 - Flags: review?(gtorodelvalle) → review+
status-b2g18: --- → affected
(Reporter)

Comment 4

6 years ago
https://github.com/mozilla-b2g/gaia/commit/22bc959a5fda94aadfb11654ad5e8eaaaaa7db6b
Status: NEW → RESOLVED
Last Resolved: 6 years ago
status-b2g18: affected → ---
Resolution: --- → FIXED
(Reporter)

Comment 5

6 years ago
Follow up of a leo+, so nominating
blocking-b2g: --- → leo?
Duplicate of this bug: 869755
Blocks: 847406
No longer depends on: 847406
leo+ -- blocking a blocker
blocking-b2g: leo? → leo+
I was not able to uplift this bug to v1-train.  If this bug has dependencies which are not marked in this bug, please comment on this bug.  If this bug depends on patches that aren't approved for v1-train, we need to re-evaluate the approval.  Otherwise, if this is just a merge conflict, you might be able to resolve it with:

  git checkout v1-train
  git cherry-pick -x -m1 22bc959a5fda94aadfb11654ad5e8eaaaaa7db6b
  <RESOLVE MERGE CONFLICTS>
  git commit
Alberto, can you help with the uplift??
Flags: needinfo?(alberto.pastor)
(Reporter)

Comment 10

6 years ago
It depends on the call log refactor, which uplift has been stop until a round of QA is executed on master. I'll uplift both together if we don't see any (important) regressions tomorrow.
Flags: needinfo?(alberto.pastor)
(Reporter)

Comment 11

6 years ago
v1-train: 4d10e1297b859cacc174c0a54af61a7678d7c32d
status-b2g18: --- → fixed

Updated

6 years ago
Flags: in-moztrap?

Updated

6 years ago
Flags: in-moztrap? → in-moztrap+

Comment 12

5 years ago
this bug appears on the firefox os 1.1.
You need to log in before you can comment on or make changes to this bug.