Only broken tegras hit PROCESS-CRASH | java-exception | java.lang.RuntimeException: Unable to instantiate instrumentation ComponentInfo{org.mozilla.roboexample.test/org.mozilla.fennec.FennecInstrumentationTestRunner}: java.lang.ClassNotFoundException: ...

RESOLVED FIXED

Status

Release Engineering
Buildduty
RESOLVED FIXED
5 years ago
4 years ago

People

(Reporter: RyanVM, Unassigned)

Tracking

({intermittent-failure})

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [badslave?])

(Reporter)

Description

5 years ago
+++ This bug was initially created as a clone of Bug #872458 +++

+++ This bug was initially created as a clone of Bug #872374 +++

+++ This bug was initially created as a clone of Bug #872372 +++

+++ This bug was initially created as a clone of Bug #872371 +++

+++ This bug was initially created as a clone of Bug #832052 +++

https://tbpl.mozilla.org/php/getParsedLog.php?id=23078171&tree=Mozilla-Inbound

Android Armv6 Tegra 250 mozilla-inbound opt test robocop-2 on 2013-05-17 06:58:33 PDT for push 32191193cbb2
slave: tegra-038

INFO | runtests.py | Running tests: start.

Robocop derived process name: org.mozilla.fennec
INFO | automation.py | Application pid: 0

INFO | automation.py | Application ran for: 0:00:01.648417
INFO | zombiecheck | Reading PID log: /tmp/tmpDZzRc5pidlog
/data/anr/traces.txt not found
PROCESS-CRASH | java-exception | java.lang.RuntimeException: Unable to instantiate instrumentation ComponentInfo{org.mozilla.roboexample.test/org.mozilla.fennec.FennecInstrumentationTestRunner}: java.lang.ClassNotFoundException: org.mozilla.fennec.FennecInstrumentationTestRunner in loader dalvik.system.PathClassLoader[/system/framework/android.test.runner.jar:/data/app/org.mozilla.roboexample.test-1.apk:/data/app/org.mozilla.fennec-1.apk]at android.app.ActivityThread.handleBindApplication(ActivityThread.java:4202)
WARNING | leakcheck | refcount logging is off, so leaks can't be detected!

INFO | runtests.py | Running tests: end.
Traceback (most recent call last):
  File "mochitest/runtestsremote.py", line 585, in main
  File "mochitest/runtestsremote.py", line 370, in addLogData
IOError: [Errno 2] No such file or directory: 'mochitest.log'
WARNING: Unable to retrieve log file (/mnt/sdcard/tests/logs/mochitest.log) from remote device
ERROR: runTests() exited with code 1
Automation Error: Exception caught while running tests
WARNING: Unable to retrieve log file (/mnt/sdcard/tests/logs/mochitest.log) from remote device
Warning: cleaning up pidfile '/builds/tegra-038/test/../runtestsremote.pid' was unsuccessful from the test harness
INFO | runtests.py | Test summary: start.
0 INFO SimpleTest START
1 INFO TEST-START | Shutdown
2 INFO Passed: 0
3 INFO Failed: 0
4 INFO Todo: 0
5 INFO SimpleTest FINISHED
(Reporter)

Comment 1

5 years ago
Bad slave disabled.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
(Assignee)

Updated

4 years ago
Product: mozilla.org → Release Engineering
You need to log in before you can comment on or make changes to this bug.