[FTU][Time zone] Text "Argentina/ComodRivadavia" wraps in selection list

RESOLVED DUPLICATE of bug 839281

Status

Firefox OS
Gaia::First Time Experience
RESOLVED DUPLICATE of bug 839281
5 years ago
5 years ago

People

(Reporter: mikeh, Assigned: mihai)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:-, b2g18+ affected)

Details

Attachments

(1 attachment)

STR:
1. BRANCH=v1.0.1 ./config.sh hamachi
2. ./build.sh
3. ./flash.sh
4. Work through the FTU/FTE wizard to the time-zone selection screen
5. Set the continent to "Americas"
6. Scroll down to "Argentina" and observe that the "ComodRivadavia" entry takes up two lines, with only the terminal "a" appearing on the second one.

I've observed this on recent builds on Hamachi, Inari, and Unagi.

I tried to grab a screenshot, but was unable to.
Visual polish, not blocking for me
Whiteboard: [tef-triage]
Minor polish, no loss of functionality or text, not blocking but tracking.
blocking-b2g: tef? → -
tracking-b2g18: ? → +
Whiteboard: [tef-triage]
Where are we getting these city timezones from? I do not remember having so many options for Argentina on any other platforms timezone selector?
Created attachment 756965 [details]
Pull Request #10147 - Truncate text label with ellipsis

A quick CSS fix which truncates overflowing labels with ellipsis (i.e. 'Argentina/Comodoro Ri...').
Attachment #756965 - Flags: review?(fernando.campo)
Hi Mihai,

Instead of showing the info as text with ellipsis, would suggest we show it with correct line break.
This has been handled with Bug 839281 for Gaia master.

Thanks.
So should I understand that this has been fixed already and mark it as duplicate?
I wouldn't like to close a bug with patch without confirmation.
Thanks
(In reply to Rudy Lu [:rudyl] from comment #5)
> Instead of showing the info as text with ellipsis, would suggest we show it
> with correct line break.
> This has been handled with Bug 839281 for Gaia master.

Hi Rudy, thanks for pointing me to that bug, it looks like that fix (which addressed the correct spelling) is only on master: https://github.com/mozilla-b2g/gaia/commit/50b75eb4c2ddfd2e7f271a25d280f3bb66d7b575, and not on v1.0.1 (as in STR), nor v1-train.

If the desired UX is to have the label on two lines with the correct line break (see attachment 720539 [details] from bug 839281), then my patch is not needed.

Can someone from the UX team confirm that the desired UX for text labels in time zone city selection from FTE is as highlighted in attachment 720539 [details] from bug 839281?

So first, I would suggest uplifting the fix for bug 839281 to v1-train and v1.0.1 (if necessary) and then, if UX confirms that no label truncation should happen, we can close this bug as duplicate.
Assignee: nobody → mihai
Depends on: 839281
Flags: needinfo?(firefoxos-ux-bugzilla)

Comment 8

5 years ago
Assigning to Francis for question on whether or not label should truncate. This is tracking+.
Flags: needinfo?(firefoxos-ux-bugzilla) → needinfo?(fdjabri)
> If the desired UX is to have the label on two lines with the correct line
> break (see attachment 720539 [details] from bug 839281), then my patch is
> not needed.

I would prefer not to truncate the string but break it over two lines, as done in bug Bug 839281. 
> 
> So first, I would suggest uplifting the fix for bug 839281 to v1-train and
> v1.0.1 (if necessary) and then, if UX confirms that no label truncation
> should happen, we can close this bug as duplicate.

I can confirm truncation isn't needed so we follow this course of action.
Flags: needinfo?(fdjabri)
Thanks Francis for your feedback, given that the correct behavior is present in the patch for bug 839281, I am marking this bug as RESOLVED > DUPLICATE.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 839281
(Assignee)

Updated

5 years ago
Attachment #756965 - Flags: review?(fernando.campo)
You need to log in before you can comment on or make changes to this bug.