Assertion failure: NS_SUCCEEDED(rv), at dom/ipc/TabChild.cpp:505

RESOLVED DUPLICATE of bug 958254

Status

Firefox OS
General
RESOLVED DUPLICATE of bug 958254
5 years ago
4 years ago

People

(Reporter: mikeh, Assigned: kentuckyfriedtakahe)

Tracking

({crash, dogfood})

unspecified
ARM
Gonk (Firefox OS)
crash, dogfood

Firefox Tracking Flags

(b2g18+ affected)

Details

Seen while trying to load https://www.youtube.com/watch?v=V1IBH1bz5-c (while trying to reproduce bug 870654).

STR:
0. BRANCH=v1.0.1 ./config.sh hamachi && ./build.sh && ./flash.sh
1. complete FTU, connecting to available WiFi
2. open the Browser app
3. go to https://www.youtube.com/watch?v=V1IBH1bz5-c

Expected results: page should open

Observed results: "Well, this is embarassing. We tried to display this Web page, but it's not responding."

logcat shows:
F(  620:0x26c) Assertion failure: NS_SUCCEEDED(rv), at /home/mikeh/dev/mozilla/m-c/b2g18/dom/ipc/TabChild.cpp:505
F(  620:0x26c) Fatal signal 11 (SIGSEGV) at 0x00000000 (code=1)

Relevant lines in the code:

   502   // by AsyncPanZoomController and causes a blurry flash.
   503   bool isFirstPaint;
   504   nsresult rv = utils->GetIsFirstPaint(&isFirstPaint);
   505   MOZ_ASSERT(NS_SUCCEEDED(rv));

http://hg.mozilla.org/releases/mozilla-b2g18/file/b87559cef261/dom/ipc/TabChild.cpp#l505

Observed with:
- gecko: b2g18:b87559cef261
- gaia: 7d0ca6a07fc3d4817f80f4ebc24314b6cbcf049a
Note: this is with a debug build, so step 0 should include |B2G_DEBUG=1 ./build.sh|.
ajones, this assertion was introduced in changeset 117519[1]; any idea what's going on here?

1. http://hg.mozilla.org/releases/mozilla-b2g18/diff/3dd36851bd7c/dom/ipc/TabChild.cpp
Flags: needinfo?(ajones)
If I comment out the above MOZ_ASSERT(), the URL https://www.youtube.com/watch?v=V1IBH1bz5-c loads correctly.
I'd expect to see a regression in bug 799401. Just need to figure out if that could possibly happen in this context. Is GetPresShell() returning nullptr?
Flags: needinfo?(ajones)
Needsinfo on Mike to see if he can with comment #4 ?
Flags: needinfo?(mhabicher)
Triage - Mike, can you describe the user impact here and if there is any occurrence rate?
Unable to make triage decision base on the bug as is.
(In reply to Wayne Chang [:wchang] from comment #6)
>
> Triage - Mike, can you describe the user impact here and if there is any
> occurrence rate? Unable to make triage decision base on the bug as is.

It happens only on DEBUG builds, so no one is going to see it in the field; but presumably the assertion exists for a reason, and it's failure is an error, so we should fix it.

It also makes debugging impossible unless you manually comment out that line of code, like I have done.
Flags: needinfo?(mhabicher)
Assignee: nobody → ajones
It should be fixed, but we can't hold a release for it, so it will have to land to v1-train and bubble up from there to v1.next releases.
blocking-b2g: leo? → ---
tracking-b2g18: ? → +
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 958254
You need to log in before you can comment on or make changes to this bug.