Closed Bug 873590 Opened 8 years ago Closed 8 years ago

Random NS_ERROR_XPC_BAD_CONVERT_NATIVE when displaying a notification since Firefox 22

Categories

(Add-on SDK Graveyard :: General, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 873742

People

(Reporter: u463949, Unassigned)

Details

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:22.0) Gecko/20100101 Firefox/22.0 (Beta/Release)
Build ID: 20130516062729

Steps to reproduce:

Display a notification using the notifications module under Firefox 22. Use either SDK 1.14 or the current trunk. Here are some parameters that triggered the bug at least once:

notifications.notify({"iconURL":"resource://jid0-9xfbwuwnvpx4wwsfbwmcm4jj69e-at-jetpack/self-destructing-cookies/data/sdc64.png","text":"from google.com self-destructed.","title":"Trackers, Cookies"})



Actual results:

Most of the time, the notification is displayed as it should. Sometimes (seems random, probably not related to the arguments used) the notification popup will not be displayed and is logged to the console instead.

Adding debugging code to lib/sdk/notifications.js indicates that an exception is caught in line 53. Here is a backtrace:

error: self-destructing-cookies: An exception occurred.
NS_ERROR_XPC_BAD_CONVERT_NATIVE: Component returned failure code: 0x8057000a (NS_ERROR_XPC_BAD_CONVERT_NATIVE) [nsIAlertsService.showAlertNotification]
Traceback (most recent call last):
  File "resource://jid0-9xfbwuwnvpx4wwsfbwmcm4jj69e-at-jetpack/addon-sdk/lib/sdk/timers.js", line 31, in notify
    callback.apply(null, args);
  File "resource://jid0-9xfbwuwnvpx4wwsfbwmcm4jj69e-at-jetpack/self-destructing-cookies/lib/main.js", line 549, in postRemoval
    GUI.actionNotification(removed, removedTracking, removedScopes, removedTrackingScopes, "self-destructed", prefs.prefs.displayNotification);
  File "resource://jid0-9xfbwuwnvpx4wwsfbwmcm4jj69e-at-jetpack/self-destructing-cookies/lib/gui-desktop.js", line 341, in exports.actionNotification
    text: msg
  File "resource://jid0-9xfbwuwnvpx4wwsfbwmcm4jj69e-at-jetpack/addon-sdk/lib/sdk/notifications.js", line 44, in notifications_notify
    notifyWithOpts(notify);
  File "resource://jid0-9xfbwuwnvpx4wwsfbwmcm4jj69e-at-jetpack/addon-sdk/lib/sdk/notifications.js", line 41, in notifyWithOpts
    valOpts.data, clickObserver);
info: self-destructing-cookies: [Trackers, Cookies] from google.com self-destructed.

This might be related to bug 852436. I have not been able to generate a simple testcase. The easiest way to reproduce this is just surfing around a bit with Firefox 22 and Self-Destructing Cookies 0.4 installed. I can trigger this pretty reliably within the first 10 pop-ups or so.


Expected results:

A notification popup is shown each time.
I encountered more issues with the new notification code in Firefox 22 - see bug 873742. I suspect that the problem is not really in the SDK itself.
Ove I'm afraid I was not able to reproduce this issue, maybe because it's platform specific and I'm on OSX. Also it looks like some related issues have being fixed under bug 871460. Also as you seem to report under bug 873742 that does not seems to be an SDK related issues, so I'm tempted to mark this one as dependent on it.
Status: UNCONFIRMED → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 873742
That's all right, I experimented some more and I'm sure the problem is in the lower layers. I'll add my observations to bug 873742.
You need to log in before you can comment on or make changes to this bug.