[B2G] [Inari] [Clock] Alarms will trigger one minute before their set time

VERIFIED WORKSFORME

Status

VERIFIED WORKSFORME
6 years ago
5 years ago

People

(Reporter: ckreinbring, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
Created attachment 751134 [details]
Log of setting and activating an alarm

Description:
A set alarm will trigger one minute earlier than the set time.  If an alarm is set to 9:45, the alarm will go off at 9:44.

Repro Steps:
1) Updated to Inari Build ID: 20130517070201
2) Launch the Clock app.
3) Tap the New Alarm icon in the upper right corner.
4) Set the time to a couple of minutes into the future and tap Done.
5) Observe the expected time for the alarm to be activated.
6) Wait for the alarm to activate and observe when it does compared to when it was set.

Actual:
The notification states that the alarm is set for one minute earlier then it was set for, and the alarm will go off one minute before the set time.

Expected:
The notification states that the alarm is set for the proper time.  The alarm goes off at the set time, no earlier or later.

Environmental Variables:
Occurs on the Inari 1.0.1 commercial RIL.
Build ID: 20130517070201
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18_v1_0_1/rev/67ac7c9e74fb
Gaia: 7d0ca6a07fc3d4817f80f4ebc24314b6cbcf049a
Version #: 18.0

Notes:
Repro frequency: 100%
Q Analysts Test Team Priority: Pri 3
See attached logcat logs for more info.
Not able to repro this using:

Gecko  http://hg.mozilla.org/releases/mozilla-b2g18_v1_0_1/rev/67ac7c9e74fb
Gaia   7d0ca6a07fc3d4817f80f4ebc24314b6cbcf049a
BuildID 20130517070201
Version 18.0

On my device the alarm is sounding at the exact time I have it set.
I cannot reproduce the issue with build 2013519070210. Will need QA's help..
Keywords: qawanted
(Reporter)

Comment 3

6 years ago
It appears to be working correctly on build 20130520070208.  Resolving as Worksforme for now.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME

Updated

6 years ago
Keywords: qawanted
(Reporter)

Comment 4

5 years ago
Still unable to repro on Inari 1.0.1 commercial RIL.  Verifying as Worksforme.

Build ID: 20130722070204
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18_v1_0_1/rev/9c62297d11b0
Gaia: 054cdc27404e2daca91d3065d9783681032b2151
Platform Version: 18.0
RIL Version: 01.00.01.019.144
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.