[B2G] [Dialer] No device microphone during phone call with speaker phone off

VERIFIED DUPLICATE of bug 875227

Status

Firefox OS
Gaia::Dialer
VERIFIED DUPLICATE of bug 875227
5 years ago
4 years ago

People

(Reporter: Allen Maxwell, Assigned: gtorodelvalle)

Tracking

({smoketest})

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

5 years ago
Created attachment 751225 [details]
LogCat of event

Description:
When making a phone call user is unable to communicate to recipient of phone call. Initiating speaker microphone will eliminate issue and will work in speaker phone off mode again. 

Repro Steps:
1) Updated to Build ID: 20130517070206
2) With speaker phone off, initiate a phone call
3) Speak into phone.

Actual:
Recipient will not hear audio from caller.

Expected:
User is able to communicate with recipient and carry on a private conversation.

Environmental Variables
Unagi v1.1 Mozillar RIL
Platform Version: B2G 18.0
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/b87559cef261
Gaia: 64b1a7b339acb21c3f074184a4e7284953856647

Notes:
Repro frequency: 100%, 3/3
Q Analysts Test Team Priority: Pri 1
See attached:
Log.txt LogCat of event.

Extra Notes:
-Issue occurs for inbound and outbound calls.
-Initiating speakerphone clears issue (Log2.txt)
(Reporter)

Comment 1

5 years ago
Created attachment 751229 [details]
LogCat while initiating speakerphone
(Reporter)

Comment 2

5 years ago
Issue also occurs on Buri v1.1/v1.0.1 Mozilla/Commercial RILs
Build ID: 20130517070201
Gecko: 67ac7c9e74fb
Gaia: 7d0ca6a07fc3d4817f80f4ebc24314b6cbcf049a
Assignee: nobody → gtorodelvalle
Created attachment 752595 [details]
LogCat with ril.debugging.enabled to true

Hi! As suggested by josea.olivera@gmail.com , I incude the logcat logs with ril.debugging.enabled to true and would kindly ask :mwu to have a look at them since on the Gaia side I do not see any problem related to this bug. This logs cover from the starting of the device to making a call to the device (confirming that the other side cannot be heard) and the hanging of the call.

Apart from this and as part of my testing, using Gecko-e227f5d I "went back in time" in Gaia using git reset to "revert" the latest commits to check if it could be a problem with anything we committed lately but the problem persisted. On the other hand, I also flashed my Unagi device with Gecko-0ab3418 (from the 5th of May) and this bug does not occur, so I tend to think that it is related to Gecko and not that much to Gaia. Any help would be more than appreciated ;-)
Flags: needinfo?(mwu)
(Reporter)

Updated

5 years ago
Keywords: smoketest
Summary: [B2G] [Unagi] [Dialer] No device microphone during phone call with speaker phone off → [B2G] [Dialer] No device microphone during phone call with speaker phone off

Comment 4

5 years ago
I don't know anything related to this. CC'ing some audio people who might know.
Flags: needinfo?(mwu)
(Reporter)

Comment 5

5 years ago
This issue is no longer reproducible on Unagi, Leo, Inari, and Buri for v1.1/v1.0.1, no both Mozilla/Commercial RILs.
Unagi:
Build ID: 20130524070209
Gecko: c4378ff5d057
Gaia: cc2fd02fd461aa12c96e02229a78293365d65264

Will resolve WFM on 5/28 if issue does not resurface, as previous.
Already Fix on 39c232e1572a
2013-05-23 18:28 +0800	rlin - Bug 875227 - No call sound when the call established, r=mwu a=tef+
thanks for your verification.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 875227

Updated

5 years ago
blocking-b2g: leo? → ---

Comment 7

4 years ago
confirming,
the issue has been fixed in bug 875227 - no audio problem while having connected call

test device info:
Gecko  http://hg.mozilla.org/releases/mozilla-b2g18/rev/4785b1353fd7
Gaia   4de4354e3a99f151a834743c7b03a041ac8db12f
Build  2013-06-03-070207
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.