Closed Bug 873742 Opened 8 years ago Closed 8 years ago

Various issues with the new notification code in Firefox 22

Categories

(Firefox :: Untriaged, defect)

22 Branch
x86_64
Linux
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 871460

People

(Reporter: u463949, Unassigned)

References

Details

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:22.0) Gecko/20100101 Firefox/22.0 (Beta/Release)
Build ID: 20130516062729

Steps to reproduce:

My add-on displays notifications using nsIAlertsService.showAlertNotification via the SDK.


Actual results:

Since Firefox 22, a number of problems have arisen.

- "NS_ERROR_XPC_BAD_CONVERT_NATIVE: Component returned failure code: 0x8057000a (NS_ERROR_XPC_BAD_CONVERT_NATIVE) [nsIAlertsService.showAlertNotification]" is sometimes thrown. I have added debugging code to verify that I pass only valid data, and I'm reasonably sure that this is not even directly related to the values of the parameters. The same call will sometimes succeed and sometimes fail.

- "NS_ERROR_FAILURE: Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIDOMWindow.outerHeight]" in chrome://global/content/alerts/alert.js, Line 107 sometimes appears in my error console when a notification is displayed. When this happens, the notification will appear for a short time, then disappear and reappear immediately. This repeats ad infinitum, yielding the error each time. There is no way to get rid of the popup.

- Firefox sometimes crashes when an add-on displays a notification while the browser is starting ("Aurora / Firefox closed unexpectedly while starting..."). Is there a way to get a backtrace when this dialog appears?

- Notifications will stick sometimes, i.e. the pop-up only vanishes after the user has interacted with it.

All of these issues happen only some of the time, but are easily reproduced when running my add-on (Self-Destructing Cookies 0.4) under Firefox 22.
I forgot to mention: this might be related to bug 852436. My add-on could at one time reliably crash Nightly by displaying a notification.
There is bug 871460 about Firefox crashing with notification used in add-on.
After experimenting some more, I am sure that the SDK is not the source of the problems. I tried interfacing directly with the alerts-service. That didn't change anything.
I'm also sure that the "NS_ERROR_XPC_BAD_CONVERT_NATIVE" error is not directly caused by the input that I supply to showAlertNotification, because the following pattern is a workaround:

for (<10 times>) {
  try {
    alertsService.showAlertNotification(<args>)
    return;
  } catch(e) {
    console.error(e);
  }
}

On my machines (all Linux boxes), the chances of a notification getting through are about 50/50.
This seems fixed on recent beta builds, it was probably related to bug 871460.
Status: UNCONFIRMED → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 871460
You need to log in before you can comment on or make changes to this bug.