Sometimes pages fail to render

RESOLVED WORKSFORME

Status

()

Firefox for Android
Toolbar
RESOLVED WORKSFORME
5 years ago
2 years ago

People

(Reporter: Andrés Corral, Unassigned)

Tracking

21 Branch
ARM
Android
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments, 1 obsolete attachment)

(Reporter)

Description

5 years ago
Created attachment 751331 [details]
Screenshot_2013-05-18-06-45-27.png

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:21.0) Gecko/20100101 Firefox/21.0 (Beta/Release)
Build ID: 20130511120803

Steps to reproduce:

Load a webpage, doesn't seem to matter which one. 
This is on a Samsung galaxy s2 running official jelly bean (4.1.2) rom


Actual results:

Sometimes a blank surface is where the page should be rendered. The page title on the titlebar is always ok and the page looks ok on the miniature that shows when you tap on the top right corner (the one that shows the number of open tabs)


Expected results:

The page should have been rendered properly.It worked properly until I updated to version 21 a few days ago
(Reporter)

Comment 1

5 years ago
Reloading doesn't help. I've been able to display correctly a non-rendered page by going to other app and then back into Firefox but non consistently.
OS: Windows 7 → Android
Hardware: x86_64 → ARM

Updated

5 years ago
Component: General → Graphics, Panning and Zooming
It would be great if you try to grab a log from the device when this happens. There are instructions at https://wiki.mozilla.org/Mobile/Fennec/Android#Using_aLogCat (since you are using Jelly Bean you will need the about:logcat add-on). You should be able to install the add-on. Then, when the problem occurs, switch to another app and back to clear the issue, and then open about:logcat in a new tab.

We have had other reports of similar problems but as of yet we don't have any way to reliably reproduce this so it's not easy to fix. Thanks for reporting it though!
Flags: needinfo?(iampiti)
(Reporter)

Comment 3

5 years ago
Created attachment 754486 [details]
Logcat report as requested

Here you are the log you requested. I did as told: Triggered the bug, went out and back into Firefox (that made the page appear correctly) and then launched logcat.
Attached as a PDF as this was the easiest way to get it out of the phone
Flags: needinfo?(iampiti)
Thanks for the log! Unfortunately it looks like Android killed FF when you switched out of it, and so the logcat only includes the log info from the second run of FF (which was started again when you switched back to it). So the part of the log corresponding to when the bug happened was lost :(

I'm fairly certain that this is a problem with our GL surface getting lost somehow. From comment 1 it sounds like switching away only fixes it sometimes, which presumably are the times that FF gets killed and restarted, so that eliminates some possible causes of this bug. I'll look at the code some more to see if I can figure out why this might be happening.

Comment 5

5 years ago
I also observed this issue reproducing very rarely, but I can not find the STR. Following the steps from comment 1, I was not able to reproduce this issue. If posible, can you please add more info on how to reproduce? Thanks.
Flags: needinfo?(iampiti)
(Reporter)

Comment 6

5 years ago
 (In reply to Pop Mihai from comment #5)
> I also observed this issue reproducing very rarely, but I can not find the
> STR. Following the steps from comment 1, I was not able to reproduce this
> issue. If posible, can you please add more info on how to reproduce? Thanks.

Sorry, I can't provide any more info to reproduce the problem (unless you want to make a more specific question). You try to load a page, sometimes the main view will show a blank area. It doesn't seem to follow any pattern. As I said the miniature window that shows when you go to switch tabs is always ok and switching out of Firefox and back usually fixes it. That's it. I might try to grab another logcat log to see if this time it grabs the problem
Flags: needinfo?(iampiti)
(Reporter)

Comment 7

5 years ago
Created attachment 755475 [details]
Another, more complete logcat report

Another logcat log, this time the log comprises a longer timespan. Hopefully this time it has useful information regarding the bug.
Created attachment 758768 [details]
Another, more complete logcat report (txt version)
Attachment #755475 - Attachment is obsolete: true
The log has a handful of different types of errors which I've seen before in isolation (and haven't caused this type of failure) and lots of memory pressure events. There's nothing in there that obviously points to the problem. I might need to put together a build with custom logging to find out what's going on.
(Reporter)

Comment 10

5 years ago
I'll be happy to test those special builds on my phone if necessary
(Reporter)

Comment 11

5 years ago
It hasn't happened yet since the update to v22. I'm not sure if I should close the bug though. Advice?

Updated

5 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.