MSDN search button does not work

VERIFIED WONTFIX

Status

Tech Evangelism Graveyard
English US
VERIFIED WONTFIX
17 years ago
3 years ago

People

(Reporter: Matt Seitz, Assigned: bc)

Tracking

Details

(URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:0.9.1+) Gecko/20010622
BuildID:    2001062204

Pressing the "Search" button at the MSDN search page does not work.

Reproducible: Always
Steps to Reproduce:
1.  Go to http://search.microsoft.com/us/dev/ 
2.  Enter any text in the Search text box
3.  Press the Search button

Actual Results:  Nothing happens, display remains unchanged.

Expected Results:  Results of MSDN search should be displayed

Problem also occurs using Milestone 0.9.1 build, does not occur with Internet
Explorer 5.5.  Microsoft recently revised the MSDN site, including the MSDN
search page.  This problem occurs with the current MSDN search page.

Comment 1

17 years ago
Build 2001062204
When I click on the seach button this appears in the javascript console:

Error: frm.elements.ig[zz] has no properties
Source File: http://search.microsoft.com/us/dev/
Line: 206
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

17 years ago
This was found on the page, if I'm not mistaken this causes the javascript to
try to access a non existing element?

for (zz = 1; zz<frm.elements["ig"].length+1;zz++)
{
if (frm.elements["ig"][zz].checked == false)
{
intCatSelected++;
if (intCatSelected == frm.elements["ig"].length)
{
alert( H_NoCatSelectedError_Txt);
return;
}
}
}


When I changed

for (zz = 1; zz<frm.elements["ig"].length+1;zz++)

to

for (zz = 0; zz<frm.elements["ig"].length;zz++)

it seems to work

so is this evangelism?
Component: Browser-General → Evangelism

Comment 3

17 years ago
it probably needs to use document.getElementById() or something.
Assignee: asa → bclary
QA Contact: doronr → zach

Comment 4

17 years ago
also, ns4 fails.
OS: Windows NT → All
(Assignee)

Comment 5

17 years ago
I have contacted Microsoft concerning these problems however due to external
factors it is clear that Evangelism is not an appropriate method of contacting
them concerning problems with their content.

Marking WONTFIX.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WONTFIX
(Reporter)

Comment 6

17 years ago
I do not see the problem using build 2001070604.

Comment 7

17 years ago
yup, this seems fixed
(Assignee)

Comment 8

17 years ago
All Evangelism Bugs are now in the Product Tech Evangelism. See bug 86997 for
details.
Component: Evangelism → US English
Product: Browser → Tech Evangelism
Version: other → unspecified

Comment 9

17 years ago
Verified per instructions at http://mozilla-evangelism.bclary.com/evangelism.html
Status: RESOLVED → VERIFIED
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.