Compound expression in message filters

RESOLVED DUPLICATE of bug 297852

Status

P2
enhancement
RESOLVED DUPLICATE of bug 297852
6 years ago
6 years ago

People

(Reporter: CarlPonder, Unassigned)

Tracking

17 Branch
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux i686; rv:21.0) Gecko/20100101 Firefox/21.0 (Beta/Release)
Build ID: 20130512194440

Steps to reproduce:

(This is an enhancement request, not a bug)
I'd like to be able to specify a message filter using a compound expression, like
if (( sender == "travelocity" ) || ( sender == "orbitz" )) and ( subject != "reservation" ) the move message into "travel" folder.
In this case I want to move what i consider the less urgent messages into the subject folders but keep the urgent ones in my incoming mail box.
I know that i can expand these into individual AND rules, but for junk mail rules in particular, the number of filters would explode.
Also, from the cases I'd be interested in, it would be enough to have a single AND condition for the filter, that would be combined with each of the OR conditions.
(Reporter)

Comment 1

6 years ago
Would it be possible for me to do this by editing the msgFilterRules.dat file directly?
I see these expressions

condition="AND (subject,begins with,BUILD) AND (from,is,Buildmeister)"

Would Thunderbird choke if I wrote something like

condition="AND ( OR (from,is,Orbitz) OR (from,is,Travelocity)) ) AND (subject.contains.reservation)"

As far as teh implementation goes, maybe you could write the logic to add the filter rules first, and figure out how to specify the input GUI later.
Severity: normal → enhancement
Priority: -- → P2

Updated

6 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 297852
You need to log in before you can comment on or make changes to this bug.