If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

if there are multiple login forms in one page firefox password manager fills each

RESOLVED WONTFIX

Status

()

Toolkit
Password Manager
RESOLVED WONTFIX
4 years ago
4 years ago

People

(Reporter: Vadim, Unassigned)

Tracking

Trunk
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:20.0) Gecko/20100101 Firefox/20.0 (Beta/Release)
Build ID: 20130409194949

Steps to reproduce:

I try to use multiple login forms on my website.


Actual results:

If site has two login forms (for example into user and administrator environments), firefox password manager fill each form, but not the form, in which user was loggined originally.


Expected results:

Firefox must remember not only username and password, but also input field names (or other form identificators). When password manager try to fill input fields it must in the first place try to find exactly the same form, witch user have submited . Only if page has no direct concurrency firefox can act like it act now.

Comment 1

4 years ago
Isn't this a duplicate of bug #457625 or at least closely related?
Reproduced on FF 20, Build ID: 20130409194949 and on Nightly (build ID: 20130521031106), User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:24.0) Gecko/20130521 Firefox/24.0
Status: UNCONFIRMED → NEW
Component: Untriaged → Password Manager
Ever confirmed: true
Product: Firefox → Toolkit
Version: 20 Branch → Trunk
(Reporter)

Comment 3

4 years ago
(In reply to Bruno Prémont from comment #1)
> Isn't this a duplicate of bug #457625 or at least closely related?

No it's not. 

It's many bugs about how password manager acts, and all of them are some kind of relative... But this reoprt describes another activity of PM than bug #457625.
This is how password manager is intended to work. Consider a page that had a user login form at the top and the bottom.

If the page doesn't want the browser to fill in a login or knows it would be inappropriate, it should set autocomplete=off on that form or field.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.