Overlay scroll bar size should not be affected by page zoom (Mac OS X)

RESOLVED DUPLICATE of bug 868416

Status

()

Core
XUL
RESOLVED DUPLICATE of bug 868416
5 years ago
5 years ago

People

(Reporter: dana, Unassigned)

Tracking

23 Branch
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:23.0) Gecko/20130518 Firefox/23.0 (Nightly/Aurora)
Build ID: 20130518004019

Steps to reproduce:

The most recent versions of Aurora have added native-looking overlay scroll bars to the Mac OS X version. These appear as expected when the page is at default zoom level, but if the zoom is increased, the scroll bars zoom in too.

Steps to reproduce:

1. Visit any scrollable page on Aurora for Mac.

2. Scroll up and down, noting the native-looking size/appearance of the overlay scroll bars.

3. Zoom the page in several times with ⌘+.

4. Scroll up and down, noting the now over-sized and (in some cases) glitchy-looking scroll bars.


Actual results:

Scroll bars increase size with page zoom.


Expected results:

Scroll bars should always stay the same size, independent of page zoom.

This is the behaviour of all native OS X applications which feature a zoom function (graphics editors, word processors, &c.), including Safari and Chrome.
I've used mozregression and find that 

Last good nightly: 2013-05-02
First bad nightly: 2013-05-03

Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=70e0955ccc87&tochange=b35170667a2f
Status: UNCONFIRMED → NEW
Component: Untriaged → XUL
Ever confirmed: true
Product: Firefox → Core
(Reporter)

Comment 2

5 years ago
Oh, in following some of the links from that page, it looks like this is actually a duplicate of bug # 868416.
(Reporter)

Updated

5 years ago
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 868416
You need to log in before you can comment on or make changes to this bug.