Closed Bug 873832 Opened 10 years ago Closed 9 years ago

FireFox 21.0 Still Does Not Work Correctly for Multiple Monitors

Categories

(Core :: XUL, defect)

21 Branch
x86_64
Windows 7
defect
Not set
normal

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: pegasus65, Unassigned)

Details

Attachments

(10 files)

Hello,
I submitted bug 808473.  This involved transparent menus, until the mouse was passed over the menu, when using multiple monitors in FF prior to v21.0.  However, now FF 21.0 is WORSE.  Now the menus do not appear on the same monitor FF is on.  The menus appear on the monitor above where FF is located if FF is on any monitor on the lower row.

I have 5 monitors on my system.  I have 3 monitors on the top row and 2 on the bottom row.  I almost always use FireFox on the bottom row.  I have included a Control Panel Display screenshot of how my system is configured.  Physically, the #5 monitor is actually located to the left of the other 4 monitors, not above the bottom row.  This is a photograph of what my system actually looks like.  The notes on this photograph are out of date though:
http://www.amazon.com/gp/customer-media/product-gallery/B001RBE7GO

With v21.0, FireFox menus now usually appear on the #5 monitor to the left.  I have included screenshots with notes which illustrate the various problems.  Look for a large red arrow which points to the menu on the monitor on the top row.  Read the text inside the red arrow which describes the problem.  These extra screenshots will be added after I add the Control Panel Screen Resolution applet.  I would add them all at once however this form does not allow this.

Thanks in advance.
This shows what happens when Firefox 21.0 is on the lower of 2 rows of monitors and you right-click on any tab to get the menu.
This shows what happens when Firefox 21.0 is on the lower of 2 rows of monitors and you click on any main menu item.
This shows what happens when Firefox 21.0 is on the lower of 2 rows of monitors and you click on the search menu to choose a different search engine.
This shows what happens when Firefox 21.0 is on the lower of 2 rows of monitors and you type to search Wikipedia.
This shows what happens when Firefox 21.0 is on the lower of 2 rows of monitors and you click on any folder on the Bookmarks Toolbar.  This is the worst of all these bugs.  I have 19 folders on my Bookmarks Toolbar.  NONE of them appear on the lower monitor.  They ALL appear on usually the #5 monitor to the upper left or the #1 monitor to the upper center.  This greatly slows me down and makes Firefox 21.0 unpleasant to use.  Please fix this bug ASAP.

Thanks in advance,
Cypherdude.
Component: Menus → XP Toolkit/Widgets: Menus
Product: Firefox → Core
I have included another screenshot.  This time it is FireFox's Show All Bookmarks window (Library).  I have also included a note.  Look for a large red arrow; you can't miss it.

It looks like it may take some time to fix this bug.  Can someone tell me where I can download FireFox v18.x on any official Mozilla site?  I did several searches but I could not find FF v18.x.
FireFox 21.0 is now incorrect in full screen view.  This screenshot shows FF21 on the bottom of 2 rows of monitors, with notes.  Look for the large arrow.  Both monitors on the bottom row are identical widescreens.  When in full screen view, FF21 only fills 2/3's of the monitor.

FF21 does not look correct on the other widescreen monitor either.
This is what FireFox 21.0 looks like in full screen view when in the center top monitor.  Notice how FF21 extends into the other 2 rightmost and lower left screens.  This is not correct.  When in the center upper screen, FF21 should stay within ONLY this screen.  This problem is new to FF21 as I never noticed this behavior before.  There are also notes in this screenshot.  Look for the large red arrow.
This screenshot shows Internet Explorer 9 in full screen mode (F11) on the bottom left monitor in a 5 monitor setup.  The Help menu is open and is correctly positioned below the Help button.  The Help menu is NOT open on the monitor above.

IE9 is also correctly positioned within the confines of the bottom left monitor.  IE9 does NOT extend beyond the borders of the monitor when in full screen mode.  IE9 does NOT overlap and cover the other monitors and windows.
This problem has been resolved and fixed.

Thank you,
Cypherdude.
Status: UNCONFIRMED → RESOLVED
Closed: 9 years ago
Resolution: --- → WORKSFORME
Component: XP Toolkit/Widgets: Menus → XUL
You need to log in before you can comment on or make changes to this bug.