[Buri][Notification]No missing call notification for the call from known number

VERIFIED FIXED

Status

Firefox OS
Gaia::Dialer
P1
normal
VERIFIED FIXED
5 years ago
4 years ago

People

(Reporter: sync-1, Assigned: alive)

Tracking

unspecified
ARM
Gonk (Firefox OS)
Bug Flags:
in-moztrap +

Firefox Tracking Flags

(blocking-b2g:tef+, b2g18 verified, b2g18-v1.0.0 wontfix, b2g18-v1.0.1 verified)

Details

(Whiteboard: [required_last_cert_round], URL)

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
AU_LINUX_GECKO_ICS_STRAWBERRY_V1.01.00.01.019.107
 Firefox os  v1.0.1
 Mozilla build ID:20130514070202
 
 +++ This bug was initially created as a clone of Bug #455707 +++
 
 DEFECT DESCRIPTION:
 (1)Make an incoming call from a known number, don't answer it.
 (2)Then end the call from the other side. 
 (3)There is no missing call notification in lock screen also not in header bar.No matter the screen is locked or not locked. --- NOK.
 (4)Go to call history, you can find the missing call item in it.
 
 Note:
 If the missing call is coming from an unknown number, it is OK. There will be notification
 
  REPRODUCING PROCEDURES:
 
  EXPECTED BEHAVIOUR:
 There should be always missing call notifications
 
  ASSOCIATE SPECIFICATION:
 
  TEST PLAN REFERENCE:
 
  TOOLS AND PLATFORMS USED:
 
  USER IMPACT:
 serious
 
  REPRODUCING RATE:
 100%
  For FT PR, Please list reference mobile's behavior:
 
 ++++++++++ end of initial bug #455707 description ++++++++++

Updated

5 years ago
blocking-b2g: --- → tef?

Comment 1

5 years ago
Here , known number means the number is saved in contacts.
Investigating.
Assignee: nobody → alive
There's a problem in dialer's lazy load mechanism.
It require Utils but doesn't load it before notification handling.


Patch coming.
Created attachment 751589 [details]
https://github.com/mozilla-b2g/gaia/pull/9871 patch for v1.0.1

This bug occurs in all branches but this patch is for 1.0.1 now.
Load Utils before notification message handler.

There may have alternative to laod Utils so if etienne has different opinions please point out.
Attachment #751589 - Flags: review?(etienne)

Updated

5 years ago
blocking-b2g: tef? → tef+

Updated

5 years ago
Whiteboard: [required_last_cert_round]
Whiteboard: [required_last_cert_round] → [required_last_cert_round] [status: needs review]
Comment on attachment 751589 [details]
https://github.com/mozilla-b2g/gaia/pull/9871 patch for v1.0.1

I'm stealing the review here because of deadlines. Code looks good, and it even worked in my tests!
Attachment #751589 - Flags: review?(etienne) → review+

Updated

5 years ago
Whiteboard: [required_last_cert_round] [status: needs review] → [required_last_cert_round] [status: needs landing]
v1.0.1: 3525cba

It doesn't look like this is applicable to v1-train or master, but please let me know if this is not correct.

Alive, do you know if this fix is applicable to v1-train or master?
status-b2g18-v1.0.1: --- → fixed
Flags: needinfo?(alive)

Updated

5 years ago
Whiteboard: [required_last_cert_round] [status: needs landing] → [required_last_cert_round] [status: fixed, may need landing on other branches]
(In reply to John Ford [:jhford] -- If you expect a reply from me, use needsinfo? instead of CC from comment #6)
> v1.0.1: 3525cba
> 
> It doesn't look like this is applicable to v1-train or master, but please
> let me know if this is not correct.
> 
> Alive, do you know if this fix is applicable to v1-train or master?

John, I will do the uplift because there're some conflict in this code section.
Flags: needinfo?(alive)
master
https://github.com/mozilla-b2g/gaia/commit/1092531a41213ca82d2058e8541557397af1bcbc

v1-train
https://github.com/mozilla-b2g/gaia/commit/c51082d92f18c4c7cdbc4f96c977be735500562a
Status: NEW → RESOLVED
Last Resolved: 5 years ago
status-b2g18: --- → fixed
status-b2g18-v1.0.0: --- → wontfix
Resolution: --- → FIXED
Whiteboard: [required_last_cert_round] [status: fixed, may need landing on other branches] → [required_last_cert_round]
Change component to dialer since this exactly is a dialer bug ;)
Component: Gaia::System → Gaia::Dialer

Comment 10

5 years ago
This issue no longer reproduces on both V1.1 and V1.0.1 User is able to see missed call notification from both a known number and unknown number. 


Leo Mozz build V1.1: 20130530070208
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/09ac1fd2959c
Gaia: 1cca9324d4444ad28c6fa99875e17abf7e8230be
Version 18.0

Buri Mozz V1.0.1 build: 20130530070213
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18_v1_0_1/rev/11b55d3ada71
Gaia: ac293ce59acc3bede083fad1b973794fa8bf0253
Version 18.0
Status: RESOLVED → VERIFIED
status-b2g18: fixed → verified
status-b2g18-v1.0.1: fixed → verified
(Reporter)

Comment 11

5 years ago
Comment from Mozilla:This issue no longer reproduces on both V1.1 and V1.0.1 User is able to see missed call notification from both a known number and unknown number. 
 
 
 Leo Mozz build V1.1: 20130530070208
 Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/09ac1fd2959c
 Gaia: 1cca9324d4444ad28c6fa99875e17abf7e8230be
 Version 18.0
 
 Buri Mozz V1.0.1 build: 20130530070213
 Gecko: http://hg.mozilla.org/releases/mozilla-b2g18_v1_0_1/rev/11b55d3ada71
 Gaia: ac293ce59acc3bede083fad1b973794fa8bf0253
 Version 18.0
Flags: in-moztrap?

Updated

4 years ago
Flags: in-moztrap? → in-moztrap+
You need to log in before you can comment on or make changes to this bug.