If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[Buri][SMS]Message thread from known number can not be opened

RESOLVED FIXED

Status

Firefox OS
Gaia::SMS
P1
normal
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: sync-1, Assigned: evanxd)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [POVB])

(Reporter)

Description

4 years ago
AU_LINUX_GECKO_ICS_STRAWBERRY_V1.01.00.01.019.107
 Firefox os  v1.0.1
 Mozilla build ID:20130514070202
 This should be a regression bug.
 
 +++ This bug was initially created as a clone of Bug #455709 +++
 
 DEFECT DESCRIPTION:
 (1)Receive one SMS from a known number(which is saved in contacts)
 (2)Go to the SMS function, in the list, try to open the message. But it can not be opened.--- NOK
 (3)If open from header bar notification, sometimes it will display empty page. Or just go to the SMS thread list--- NOK
 
 
 Note: Messages from an unknown number(Which is not saved in contacts) are normal. Can not opened normally.
 
  REPRODUCING PROCEDURES:
 
  EXPECTED BEHAVIOUR:
 Messages should always be opened.
 
  ASSOCIATE SPECIFICATION:
 
  TEST PLAN REFERENCE:
 
  TOOLS AND PLATFORMS USED:
 
  USER IMPACT:
 Serious
 
  REPRODUCING RATE:
 100%
  For FT PR, Please list reference mobile's behavior:
 
 ++++++++++ end of initial bug #455709 description ++++++++++

Updated

4 years ago
blocking-b2g: --- → tef?
We would probably need the number for test in order to know if this bug is caused by number normalization. Is it possible to share it in private?
(Assignee)

Comment 2

4 years ago
Hi all,

I couldn't reproduce this bug.

We use the Buri device and the 20130514070202 build.

I think that we need the QA support.

Thanks. :)
(Assignee)

Updated

4 years ago
Keywords: qawanted
(Assignee)

Updated

4 years ago
Assignee: nobody → evanxd

Comment 3

4 years ago
Just try use the same build on buri phone and follow the step, Can't reproduce the bug.

Gaia:     e6f76bc32e05928f447d66a0eedf990ba0575a80
Gecko:    http://hg.mozilla.org/releases/mozilla-b2g18/rev/884ad1bbe24e
BuildID   20130507070204
Version   18.0

phone number: 
receiver: +886978725100
sender: +886958028017

scenario 
1: Sender call receiver, receiver uses call log to create contact; perform reproduce steps
2: Directly add contact and the perform reproduce steps

Comment 4

4 years ago
[update]
test with below build info as well

Gaia:     104b7a7ff81b10f422e1b11d052520251c69bd00
Gecko:    http://hg.mozilla.org/releases/mozilla-b2g18_v1_0_1/rev/67ac7c9e74fb
BuildID   20130517070201
Version   18.0
i can reproduce on partner buri build (dated May 15th)

Comment 6

4 years ago
Reproduce success with partner's build.

build: 20130515.cfg

Gaia:     acf4a89a0deac456d6c7d49e31a4188722e36eae
  B-D     2013-05-15 15:42:33
Gecko:   
BuildID   20130515163004
Version   18.0
Can we get more details? phone number used, logs, etc...
Flags: needinfo?(pyang)
(Assignee)

Comment 8

4 years ago
Hi all,

After we checked the bug, the conclusion was that the bug was already fixed in  v1.0.1 branch. And the commit number is ee70d7517689116622c5125ce33e56d46dd3c948.

Please update the Gaia code in v1.0.1 branch.

And we could close the bug, right?
Thanks. :)
(Assignee)

Comment 9

4 years ago
Hi sync-1,

We reset to 9648799c2e45917ff150fa9eef8aeac79a9ac008 commit(the first commit in May 15)and 41eb1834798384a0ba4f64dcb19f987ac6c66d55 commit(the last commit in May 15) to test the bug. 

And we couldn't reproduce the bug with these builds in v1.0.1 branch. So the bug was NOT related with v1.0.1 branch.

We couldn't find the acf4a89a0deac456d6c7d49e31a4188722e36eae commit in v1.0.1 branch. So it's a customized build.

Could you give us the commit hash of v1.0.1 branch you used? And we could check the bug.

Thanks. :)
(Assignee)

Updated

4 years ago
Flags: needinfo?(sync-1)

Comment 10

4 years ago
The patch you mentioned in comment 8 was committed in 05/15?
our 0515 build was based on 0514 mozilla build.

if the patch was committed in 05/15,our build does not have it.
Flags: needinfo?(sync-1)
removing qawanted per comment 6.   paul, dont forget to remote this keyword when you have completed testing investigations.

Updated

4 years ago
Keywords: qawanted
(Assignee)

Comment 12

4 years ago
Hi buri.blff,

The thing is that, to use the cfg file is only way we could reproduce this bug currently.
So we used the 20130515.cfg to reproduce this bug.

Then we checked the commits in v1.0.1 branch in 5/15.
And the testing result is on the Comment 9.

Could you tell us that which mozilla build was your 0515 build based on?
(Assignee)

Comment 13

4 years ago
Hi all,

I checked the log in 20130515.cfg build.
And there are NO error log related with SMS App.
(Assignee)

Comment 14

4 years ago
Hi all,

In AU_LINUX_GECKO_ICS_STRAWBERRY_V1.01.00.01.019.107.xml file, we could know the Gaia vision is 57188a05fe5b669fc98bfcc18a49c9b3effdac06.

Then we used the 20130515.cfg build and reset gaia with 57188a05fe5b669fc98bfcc18a49c9b3effdac06 version. And we could not reproduce the bug in it.

So there might be some customizations procured the bug.

Thanks. :)
Set [POVB] according to above.
Whiteboard: [POVB]

Comment 16

4 years ago
Sorry. The bug is caused by the collision of modification from yours and us. We have fixed it.
Thanks Evan for looking into this.
resolve fixed per comment 16
Status: NEW → RESOLVED
blocking-b2g: tef? → ---
Last Resolved: 4 years ago
Resolution: --- → FIXED
(Assignee)

Comment 18

4 years ago
Hi Joe,

No problem.

It's great the bug was resolved.

And I learned how to handle this kind of situation. :)

Updated

4 years ago
Flags: needinfo?(pyang)
You need to log in before you can comment on or make changes to this bug.