[Buri][GCF][STK] case 27.22.4.5.1/1 failed

RESOLVED FIXED in 1.0.1 IOT3 (3jun)

Status

Firefox OS
Gaia
P1
normal
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: sync-1, Assigned: frsela)

Tracking

unspecified
1.0.1 IOT3 (3jun)
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:tef+, b2g18 affected, b2g18-v1.0.1 fixed)

Details

(Whiteboard: [status: update needed])

Attachments

(2 attachments)

(Reporter)

Description

5 years ago
SW12A
 AU_LINUX_GECKO_ICS_STRAWBERRY_V1.01.00.01.019.105
 Firefox os  v1.0.1
 Mozilla build ID:20130512070209
 
 
 
 +++ This bug was initially created as a clone of Bug #455565 +++
 
 DEFECT DESCRIPTION:
 [GCF][STK] case 27.22.4.5.1/1 PLAY TONE failed
 
 
  REPRODUCING PROCEDURES:
 1 run GCF case 27.22.4.5.1/1 PLAY TONE ,in step 96 ,PROACTIVE COMMAND: PLAY 
 TONE 1.1.16, no tone play--->KO
 
 
  EXPECTED BEHAVIOUR:
 as spec 51.010-4,[Command performed successfully], [ME uses general beep, or if not supported any (defined by ME-manufacturer) other supported tone, uses default duration defined by ME-manufacturer] 
 
  ASSOCIATE SPECIFICATION:
 
  TEST PLAN REFERENCE:
 
  TOOLS AND PLATFORMS USED:
 
  USER IMPACT:
 
  REPRODUCING RATE:
 
  For FT PR, Please list reference mobile's behavior:
 
 ++++++++++ end of initial bug #455565 description ++++++++++
 
 
 
 CONTACT INFO (Name,Phone number):
 
  DEFECT DESCRIPTION:
 
  REPRODUCING PROCEDURES:
 
  EXPECTED BEHAVIOUR:
 
  ASSOCIATE SPECIFICATION:
 
  TEST PLAN REFERENCE:
 
  TOOLS AND PLATFORMS USED:
 
  USER IMPACT:
 
  REPRODUCING RATE:
 
  For FT PR, Please list reference mobile's behavior:

Comment 1

5 years ago
This bug is GCF block.
blocking-b2g: --- → tef?
In order to clarify, the issue is that the tone is not heared?

By default, these are de recognized tones:
https://github.com/mozilla-b2g/gaia/blob/master/apps/settings/js/icc.js#L793

we don't defined a DEFAULT tone, if it's needed I can add it in a little patch
Flags: needinfo?(sync-1)

Comment 3

5 years ago
Hi Fernando,

From TS 102 223, section 6.6.5, I see this under the description for Tone:

- If no tone is specified, then the Terminal shall default to "general beep".

Currently, this is being sent up for this particular case:
RILContentHelper: Received message 'RIL:StkCommand': {"commandNumber":1,"typeOfCommand":32,"commandQualifier":0,"options":{"text":""}}

If more info needs to be sent, please let me know.
Flags: needinfo?(frsela)
Thank you Carol. So a default entry should be added to the switch ;)
It's a easy fix :p
Flags: needinfo?(frsela)

Comment 5

5 years ago
I will check this bug again.
Flags: needinfo?(sync-1)

Comment 6

5 years ago
we has add DEFAULT tone as follow:

           break;
      case icc.STK_TONE_TYPE_NEGATIVE_ACK_TONE:
        selectedPhoneSound = 'resources/dtmf_tones/300Hz+400Hz+500Hz_400ms.ogg';
        break;
      default :
        selectedPhoneSound = 'resources/dtmf_tones/350Hz+440Hz_200ms.ogg';


but the tone dosen't play.
(In reply to buri.blff from comment #6)
> we has add DEFAULT tone as follow:
> 
>            break;
>       case icc.STK_TONE_TYPE_NEGATIVE_ACK_TONE:
>         selectedPhoneSound =
> 'resources/dtmf_tones/300Hz+400Hz+500Hz_400ms.ogg';
>         break;
>       default :
>         selectedPhoneSound = 'resources/dtmf_tones/350Hz+440Hz_200ms.ogg';
> 
> 
> but the tone dosen't play.

mmmm ... could you provide traces with DEBUG enabled in system/js/icc_cache.js and settings/js/utils.js ?

also you can check if timeout https://github.com/mozilla-b2g/gaia/blob/master/apps/settings/js/icc.js#L838 is too short

this timeout is calculated a few lines before...

Comment 8

5 years ago
Created attachment 752604 [details]
the log main with the flag be true

Comment 9

5 years ago
According the log, the tone of this case with default time out is 2000ms, and the tonePlayer.play(); executed. Buth there is no play tone ring.

there is another 2000ms tone above, it play success.
Looking to the logcat, it appears all is working well, a sound has been selected and started to play it for 2 secs

Can you set another sound file to assure is it correct? now you're using resources/dtmf_tones/350Hz+440Hz_200ms.ogg
Flags: needinfo?(buri.blff)

Comment 11

5 years ago
we has set two other sound,'resources/dtmf_tones/400Hz_200ms.ogg','resources/dtmf_tones/300Hz+400Hz+500Hz_400ms.ogg'. and set the time out longer to 100000. There is still no tone play.
Flags: needinfo?(buri.blff)

Updated

5 years ago
Flags: needinfo?(jcheng)
comment 11 to frsela. thanks
Flags: needinfo?(jcheng) → needinfo?(frsela)

Comment 13

5 years ago
mozilla please update status;
Fernando, can you try to fix this? It seems like low effort, close to null risk.
blocking-b2g: tef? → tef+
status-b2g18: --- → affected
status-b2g18-v1.0.1: --- → affected
(Reporter)

Comment 15

5 years ago
Comment from Mozilla:Fernando, can you try to fix this? It seems like low effort, close to null risk.
per comment 14, assignee to frsela. please unassign yourself if you don't believe you are the correct owner. thanks
Assignee: nobody → frsela
(Reporter)

Comment 17

5 years ago
Comment from Mozilla:per comment 14, assignee to frsela. please unassign yourself if you don't believe you are the correct owner. thanks
batch update on tef+ milestones. partner to make a final on 6/3 Asia time. TEF+ needs to be resolved by 6/3 to be in the final build. thanks
Target Milestone: --- → 1.0.1 IOT3 (3jun)
Whiteboard: [status: update needed]
Created attachment 757350 [details]
Added default sound if no specified by the ICC command

This patch shall be merged in V1.0.1 directly since in master is not working well the STK settings code.
Attachment #757350 - Flags: review?(kaze)
Flags: needinfo?(frsela)
Comment on attachment 757350 [details]
Added default sound if no specified by the ICC command

Hey Fernando, this looks good to me but please have a look at my comment on the github PR. Thanks!
Attachment #757350 - Flags: review?(kaze) → review+
Thanks Kaze! I answered you on github.

Merged https://github.com/mozilla-b2g/gaia/commit/00b56e8de6f83104930ba4ff0931b6155d9e7c43
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
this is fixed on v1.0.1, marking the status as such
status-b2g18-v1.0.1: affected → fixed
You need to log in before you can comment on or make changes to this bug.