[b2g-bluetooth] Remove old system messages for Bluetooth pairing requests

RESOLVED FIXED

Status

defect
RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: gyeh, Assigned: gyeh)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [fixed-in-birch])

Attachments

(1 attachment, 2 obsolete attachments)

Old system messages are combined into one new message typed "bluetooth-pairing-request", so they should be retired after Settings App migrates to new message (bug 873917).
Assignee: nobody → gyeh
Comment on attachment 764514 [details] [diff] [review]
Patch 1(v1): Remove old system messages for Bluetooth pairing requests

Review of attachment 764514 [details] [diff] [review]:
-----------------------------------------------------------------

ok, I can confirm that other stuff is good, but I'm not sure if the line I comment at is correct or not. Feedback? mrbkap since we need feedback from expert ;)

::: dom/bluetooth/BluetoothService.cpp
@@ +756,3 @@
>  
>    AutoSafeJSContext cx;
> +  JS::Rooted<JSObject*> obj(cx);

Question: shouldn't it be JS::Rooted<JSObject*> obj(cx, JS_NewObject(cx, NULL, NULL, NULL))?
Attachment #764514 - Flags: review?(echou)
Attachment #764514 - Flags: review+
Attachment #764514 - Flags: feedback?(mrbkap)
(In reply to Eric Chou [:ericchou] [:echou] (6/25 ~ 28 @ Shanghai, GSMA MAE) from comment #2)
> ::: dom/bluetooth/BluetoothService.cpp
> @@ +756,3 @@
> >  
> >    AutoSafeJSContext cx;
> > +  JS::Rooted<JSObject*> obj(cx);
> 
> Question: shouldn't it be JS::Rooted<JSObject*> obj(cx, JS_NewObject(cx,
> NULL, NULL, NULL))?

Agree. I think we should use |JS_NewObject(cx, nullptr, nullptr, nullptr)|. Or, obj would be a null pointer.

Let me update patch and confirm with mrbkap :)
Attachment #764514 - Attachment is obsolete: true
Attachment #764514 - Flags: feedback?(mrbkap)
Attachment #764578 - Flags: review?(echou)
Attachment #764578 - Flags: feedback?(mrbkap)
Comment on attachment 764578 [details] [diff] [review]
Patch 1(v2): Remove old system messages for Bluetooth pairing requests

Review of attachment 764578 [details] [diff] [review]:
-----------------------------------------------------------------

:)
Attachment #764578 - Flags: review?(echou) → review+
Comment on attachment 764578 [details] [diff] [review]
Patch 1(v2): Remove old system messages for Bluetooth pairing requests

Yep, this is right.
Attachment #764578 - Flags: feedback?(mrbkap) → feedback+
Thanks, mrbkap. :)
https://hg.mozilla.org/mozilla-central/rev/f2e3f99ec1d0
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.