If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

HTTP headers can't be used to control font caching [e.g. woff fonts], and shift+reload doesn't redownload them

RESOLVED DUPLICATE of bug 862222

Status

()

Core
Graphics
RESOLVED DUPLICATE of bug 862222
4 years ago
4 years ago

People

(Reporter: jwatt, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

It seems like HTTP headers can't be used to control font caching. Say I have an @font-face rule in my page that loads a woff font, then I hit shift-reload, the devtools Network tab shows that only the page is re-requested. No request is made for the woff font. This is even the case if I send the following HTTP headers with the font:

 Pragma: no-cache
 Cache-Control: max-age=0, no-cache, no-store, must-revalidate
 Expires: 0
 X-Cache-Info: not cacheable; response specified "Cache-Control: private"

I'm not sure which part of the system is to blame, but I'm guessing probably not netwerk.
Yeah... the effect you're seeing is not due to "normal" network-level caching but rather to the sharing of the actual font instance, implemented in bug 816483.

As bug 862222 says, we really should have some way for people to explicitly bypass this.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 862222
You need to log in before you can comment on or make changes to this bug.