Plugin Check Page says Google Earth Plugin is out of date.

RESOLVED INVALID

Status

RESOLVED INVALID
6 years ago
6 years ago

People

(Reporter: rob1weld, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

6 years ago
When I visit https://www.mozilla.org/en-US/plugincheck/ it says:

Outdated Plugins 
Plugin 				Status 		Action
Google Earth Plugin		vulnerable	Update Now
GEPlugin


Bug 1: When I click on the [Update Now] Button it reloads the Page instead of taking me to GE's Site. 

Bug 2: When I visit http://www.google.com/earth/explore/products/plugin.html it says: "Good news, you already have the Google Earth Plug-in installed. (Version 7.0.2.8415)".


The 'Update Button' is falsely reporting that my version of the GE Plugin is too old, but GE's Site thinks it is 'new enough', and won't offer a download link. 

The 'Update Button' should open a new Tab and take us to http://www.google.com/earth/explore/products/plugin.html .
(Reporter)

Updated

6 years ago
Summary: Google Earth → Plugin Check Page says Google Earth Plugin is out of date.
Component: Plug-ins → plugins.mozilla.org
Product: Core → Websites
QA Contact: cbook
A newer version 7.0.3.8542 is available, according to Bug 853506. And the newest version is 7.1.1.1580, according to the official release notes:
http://support.google.com/earth/bin/answer.py?hl=en&answer=40901
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.