The load event seems to be removed after switching the application

RESOLVED DUPLICATE of bug 920890

Status

Firefox OS
Gaia
--
major
RESOLVED DUPLICATE of bug 920890
5 years ago
4 years ago

People

(Reporter: nbp, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

5 years ago
Created attachment 751932 [details]
logcat

Unagi, while running on top of:

Gecko  http://hg.mozilla.org/mozilla-central/rev/6c48ce88a31ad3476e3403008a02b589ac44e2ba
Gaia   4e2d757cc50d41c7614c1c1ebf039f21781a5e3b
BuildID 20130510022420
Version 23.0a1

STR:
1. Start with all apps closed
2. Rapidly opening the browser, messages, contact & dialer and switch after opening each app (press an app, then the home button before the start of the painting).
3. Long Press to open card view, and wait until screenshots appear.
4. Tap the Dialer.

Actual:
 - The status bar appear as totally black.  In some cases, the dialer CSS / JS is not present.

Expected:
 - Should be able to dial a number after switching to the dialer.


Note:  GC appears in this logcat as they are enabled with the gecko preference flag.  Manually causing memory pressure during the load does not seems to impact the load of any application.
(Reporter)

Comment 1

5 years ago
Created attachment 751933 [details]
screenshot of the dialer
(Reporter)

Comment 2

5 years ago
Change the tracking flag, as this bug cannot be reproduced on the 1.0.1.

PS: What is the difference between "leo?" and "kio?", when would we get version numbers which are matching with what is *found on the phone*?
blocking-b2g: tef? → koi?
(In reply to Nicolas B. Pierron [:nbp] from comment #2)
> Change the tracking flag, as this bug cannot be reproduced on the 1.0.1.
> 
> PS: What is the difference between "leo?" and "kio?", when would we get
> version numbers which are matching with what is *found on the phone*?

koi = 1.2 - blockers for central or master builds
leo = 1.1 - blockers for v1train or b2g18 builds
(Reporter)

Comment 4

5 years ago
(In reply to Jason Smith [:jsmith] from comment #3)
> koi = 1.2 - blockers for central or master builds
> leo = 1.1 - blockers for v1train or b2g18 builds

Thanks.  So "koi" is the right tracking flag for this bug.
Request to try this on 1.2 and corresponding gecko to see if this still reproduces and renom accordingly.
blocking-b2g: koi? → ---
(Reporter)

Comment 6

4 years ago
I can still reproduce it on a build from the Monday of the Oslo work week.
(Reporter)

Comment 7

4 years ago
(In reply to Nicolas B. Pierron [:nbp] from comment #6)
> I can still reproduce it on a build from the Monday of the Oslo work week.

I tried it on one of JulienW phones, and I was able to reproduce it.
This bug sounds like a duplicate of Bug 920890.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 920890
You need to log in before you can comment on or make changes to this bug.