Saving media files from browser app doesn't respect the default Device Storage location in Settings

RESOLVED DUPLICATE of bug 875637

Status

RESOLVED DUPLICATE of bug 875637
6 years ago
6 years ago

People

(Reporter: jeremykimleo, Unassigned)

Tracking

unspecified
1.1 QE2 (6jun)
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: MiniWW)

(Reporter)

Description

6 years ago
STR >
Settings -> Media storage -> Default media location "SD Card"
Save any images on some page on browser app.

Browser Apps always saves those image on Internal memory.
But, currently media location is "SD Card" as default.

Expected behavior >
browser should save to default media location when it saves something(IMAGE/VIDEO/AUDIO).

Test Revision Information
Gecko's Revision : ada3b9647e60742aacee32918596c0ae022df1cb
Gaia's Revision  : 0d5f55fef5b46b8a53b87daed9abe3b9a37ce322

Updated

6 years ago
Target Milestone: --- → 1.1 QE2
Which branch is this reproducing on?

I know there have been some changes to Device Storage lately, but I'm not sure which branches those changes have been applied to.

The browser app just calls navigator.getDeviceStorage(storageType) with storageType "pictures", "videos" or "music" and uses the addNamed() method to save the files.

On the dev-b2g mailing list Dave Hylands says "Now when you call addNamed('DCIM/foo.jpg') and the setting is set to extsdcard, then the file would goto /extsdcard/DCIM/foo.jpg"

That makes it sound like this should "just work" with the current implementation in the browser, saving the file to the correct default location.

Dave, do you have any idea what's going on here?
Flags: needinfo?(dhylands)
Summary: Browser can't save to external memory after works device storage for internal/external memory. → Saving media files from browser app doesn't respect the default Device Storage location in Settings
It sounds like it should be in the "just works" category. I'll see if I can reproduce the problem.

I have a patch which allows a second volume to be added to a phone which doesn't otherwise have 2 volumes (if you're interested).
Flags: needinfo?(dhylands)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 875637

Updated

6 years ago
Whiteboard: MiniWW
You need to log in before you can comment on or make changes to this bug.