bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

[Buri][GCF][STK]case 27.22.4.9.2/1 (SELECT ITEM, next action indicator, successful) failed

RESOLVED FIXED

Status

Firefox OS
Gaia::Settings
P1
normal
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: sync-1, Assigned: frsela)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:leo+, b2g18 fixed, b2g-v1.1hd fixed)

Details

(Whiteboard: QARegressExclude)

Attachments

(4 attachments)

(Reporter)

Description

5 years ago
AU_LINUX_GECKO_ICS_STRAWBERRY_V1.01.00.01.019.105
 Firefox os  v1.0.1
 Mozilla build ID:20130512070209
 
 
 
 +++ This bug was initially created as a clone of Bug #455580 +++
 
 DEFECT DESCRIPTION:
 [GCF][STK]case 27.22.4.9.2/1 (SELECT ITEM, next action indicator, successful) failed
 
  REPRODUCING PROCEDURES:
 
 1 run GCF case 27.22.4.9.2/1 (SELECT ITEM, next action indicator, successful) ;
 2 at step4, can not display next action indicator at select item command--->KO
 
 
 similar bug 407666 
 
  EXPECTED BEHAVIOUR:
 as spec 51.010-4 ,The Terminal may indicate to the user the consequences of performing the selection of an item.
 
  ASSOCIATE SPECIFICATION:
 
  TEST PLAN REFERENCE:
 
  TOOLS AND PLATFORMS USED:
 
  USER IMPACT:
 
  REPRODUCING RATE:
 
  For FT PR, Please list reference mobile's behavior:
 
 ++++++++++ end of initial bug #455580 description ++++++++++
 
 
 
 CONTACT INFO (Name,Phone number):
 
  DEFECT DESCRIPTION:
 
  REPRODUCING PROCEDURES:
 
  EXPECTED BEHAVIOUR:
 
  ASSOCIATE SPECIFICATION:
 
  TEST PLAN REFERENCE:
 
  TOOLS AND PLATFORMS USED:
 
  USER IMPACT:
 
  REPRODUCING RATE:
 
  For FT PR, Please list reference mobile's behavior:
(Reporter)

Comment 1

5 years ago
Clone from brother
(Reporter)

Comment 2

5 years ago
Created attachment 751975 [details]
snapshot

Clone from brother

Comment 3

5 years ago
This bug is GCF block;
blocking-b2g: --- → tef?
frsela, do you need logs for this one too? Thanks
Flags: needinfo?(frsela)

Comment 5

5 years ago
This looks a lot like: https://bugzilla.mozilla.org/show_bug.cgi?id=847034#c5

Specifically, comment 5 for bug 847034 mentioned that this is not blocking. Can someone please confirm?
Flags: needinfo?(buri.blff)
Trying to understand this better.

with "can not display next action indicator at select item command" you mean the backward arrow in the top-left corner?
Flags: needinfo?(frsela) → needinfo?(sync-1)

Comment 7

5 years ago
Created attachment 752575 [details]
The right screen short of other devices

we should give indicator as the image
Flags: needinfo?(buri.blff)

Updated

5 years ago
Flags: needinfo?(sync-1)

Comment 8

5 years ago
And we need to consider there will be several language.

Comment 9

5 years ago
This is GCF block.

Comment 10

5 years ago
FYI, the default Android code does not support 'Next Action Indicator'.

Daniel, thoughts on this being a blocker?
Flags: needinfo?(dcoloma)
(In reply to buri.blff from comment #7)
> Created attachment 752575 [details]
> The right screen short of other devices
> 
> we should give indicator as the image

Ok, you mean the little text ... :p
In which field of the received JSON is it stored? can you provide logs with gaia debug level enabled to check if the platform is sending this data?

Thanks
Flags: needinfo?(sync-1)

Comment 12

5 years ago
(In reply to Fernando R. Sela [:frsela] from comment #11)
> (In reply to buri.blff from comment #7)
> > Created attachment 752575 [details]
> > The right screen short of other devices
> > 
> > we should give indicator as the image
> 
> Ok, you mean the little text ... :p
> In which field of the received JSON is it stored? can you provide logs with
> gaia debug level enabled to check if the platform is sending this data?

Commercial RIL does not send this info up (note that as mentioned in Comment 10, Android does not support this either). To support this, it would require change from both Commercial RIL and Gaia.

> 
> Thanks
Clearly not something we can do in 1.0.1 timeframe. Carol, is this functionality added for 1.1 Commercial Ril?
Flags: needinfo?(dcoloma) → needinfo?(cyang)
Whiteboard: [tef-triage]

Comment 14

5 years ago
(In reply to Daniel Coloma:dcoloma from comment #13)
> Clearly not something we can do in 1.0.1 timeframe. Carol, is this
> functionality added for 1.1 Commercial Ril?

We can add this to 1.1 Commericial RIL but would also need Gaia support for this to be complete though.
Flags: needinfo?(cyang)

Comment 15

5 years ago
This is GCF block case. Can we only resolve it in v1.1 in the future??

Comment 16

5 years ago
(In reply to Fernando R. Sela [:frsela] from comment #11)
> (In reply to buri.blff from comment #7)
> > Created attachment 752575 [details]
> > The right screen short of other devices
> > 
> > we should give indicator as the image
> 
> Ok, you mean the little text ... :p
> In which field of the received JSON is it stored? can you provide logs with
> gaia debug level enabled to check if the platform is sending this data?
> 
> Thanks

yes, as the The right screen short of other devices show, there is an little text such as "send sms" in Item1 to tell user what's the function of the item1.

Updated

5 years ago
Flags: needinfo?(sync-1)

Comment 17

5 years ago
mozilla please update pr status. thanks.

Comment 18

5 years ago
the qcom case id:01202376

Comment 19

5 years ago
Fernando, can you please let me know the JSON you expect for the 'Next Action Indicator'?
Flags: needinfo?(frsela)
blocking-b2g: tef? → leo+
Whiteboard: [tef-triage]

Comment 20

5 years ago
this is block certification, please update status. thanks.
(In reply to Carol Yang from comment #19)
> Fernando, can you please let me know the JSON you expect for the 'Next
> Action Indicator'?

I don't have any special preference :)

For example "nai" :p
Flags: needinfo?(frsela)

Comment 22

5 years ago
Ok, so something Commercial RIL will send something like this up:

RILContentHelper: Received message 'RIL:StkCommand': {"commandNumber":1,"typeOfCommand":37,"commandQualifier":0,"options":{"title":"SIM Toolkit","items":[{"identifier":128,"text":"Item 1","nai":"Send sms"},{"identifier":129,"text":"Item 2","nai":"Set Up Call"},{"identifier":130,"text":"Item 3","nai":"Provide Local Information"}],"presentationType":0}}
Created attachment 761339 [details]
Adding STK next action indicator support
Attachment #761339 - Flags: review?(kaze)

Comment 24

5 years ago
Hi Fernando, 
Do you expect an empty string (nai: '') if there is no Next Action Indicator tag or just no nai tag at all in the message?
(In reply to Nivi from comment #24)
> Hi Fernando, 
> Do you expect an empty string (nai: '') if there is no Next Action Indicator
> tag or just no nai tag at all in the message?

Both are Ok

Comment 26

5 years ago
Cool. Am sending empty string for now. :)
Thanks.

Comment 27

5 years ago
ferjm -

We need to send some key strings to Gaia for displaying the Next Action Indicator on the Set up menu. Here's a list of them and the default English strings.

stkItemsNaiSetUpCall- Set Up Call
stkItemsNaiSendSs - Send SS
stkItemsNaiSendUssd - Send USSD
stkItemsNaiSendSms - Send SMS
stkItemsNaiSendDtmf - Send DTMF
stkItemsNaiLaunchBrowser - Launch Browser
stkItemsNaiPlayTone - Play Tone
stkItemsNaiDisplayText - Display Text
stkItemsNaiGetInkey - Get Inkey
stkItemsNaiGetInput - Get Input
stkItemsNaiSelectItem - Select Item
stkItemsNaiSetUpMenu - Set Up Menu
stkItemsNaiProvideLocalInfo - Provide Local Info
stkItemsNaiSetIdleModeText - Set Idle Mode Text
stkItemsNaiOpenChannel - Open Channel
stkItemsNaiCloseChannel - Close Channel
stkItemsNaiReceiveData - Receive Data
stkItemsNaiSendData - Send Data
stkItemsNaiGetChannelStatus - Get Channel Status

Can you add these too along with the Mmi codes [bugzilla 879032]?

Nivi.
Flags: needinfo?(ferjmoreno)

Updated

5 years ago
Assignee: nobody → frsela

Comment 28

5 years ago
Hi Fernando (frsela),

I grabbed your gaia patch for displaying nai and tested with it. I don't see the nai string being displayed on the Toolkit menu. I am sending you this string - {commandNumber : 1,                         typeOfCommand : 37,                         commandQualifier : 0, options : {title : 'Toolkit Menu', items:[{identifier : 1,text : 'Item 1',nai : 'stkItemsNaiSendSms'},{identifier : 2,text : 'Item 2',nai : 'stkItemsNaiSetUpCall'},{identifier : 3,text : 'Item 3',nai : 'stkItemsNaiLaunchBrowser'},{identifier : 4,text : 'Item 4',nai : 'stkItemsNaiProvideLocalInfo'}], presentationType : 0}}

Can you please test with this?

Comment 29

5 years ago
Hi Fernando (frsela),

You need this patch as well in addition to yours -

diff --git a/apps/settings/js/icc.js b/apps/settings/js/icc.js
index 458acfd..a4f6f75 100644
--- a/apps/settings/js/icc.js
+++ b/apps/settings/js/icc.js
@@ -487,6 +487,7 @@
         iccStkList.appendChild(buildMenuEntry({
           id: 'stk-menuitem-' + menuItem.identifier,
           text: menuItem.text,
+          nai: menuItem.nai,
           onclick: onMainMenuItemClick,
           attributes: [['stk-menu-item-identifier', menuItem.identifier]]
         }));

With this change, I can see the Nai string on the menu.

Nivi.
(In reply to Nivi from comment #29)
> Hi Fernando (frsela),
> 
> You need this patch as well in addition to yours -
> 
> diff --git a/apps/settings/js/icc.js b/apps/settings/js/icc.js
> index 458acfd..a4f6f75 100644
> --- a/apps/settings/js/icc.js
> +++ b/apps/settings/js/icc.js
> @@ -487,6 +487,7 @@
>          iccStkList.appendChild(buildMenuEntry({
>            id: 'stk-menuitem-' + menuItem.identifier,
>            text: menuItem.text,
> +          nai: menuItem.nai,
>            onclick: onMainMenuItemClick,
>            attributes: [['stk-menu-item-identifier', menuItem.identifier]]
>          }));
> 
> With this change, I can see the Nai string on the menu.
> 
> Nivi.

Oh, yeah ! I supposed NAI was only for "SELECT_ITEM" menues and not for the main one.

Thanks ! I'll fix it now.
Fixed. One question: Help menus should support NAI too?
Flags: needinfo?(nsarkar)
(In reply to Nivi from comment #27)
> ferjm -
> 
> We need to send some key strings to Gaia for displaying the Next Action
> Indicator on the Set up menu. Here's a list of them and the default English
> strings.
> 
> stkItemsNaiSetUpCall- Set Up Call
> stkItemsNaiSendSs - Send SS
> stkItemsNaiSendUssd - Send USSD
> stkItemsNaiSendSms - Send SMS
> stkItemsNaiSendDtmf - Send DTMF
> stkItemsNaiLaunchBrowser - Launch Browser
> stkItemsNaiPlayTone - Play Tone
> stkItemsNaiDisplayText - Display Text
> stkItemsNaiGetInkey - Get Inkey
> stkItemsNaiGetInput - Get Input
> stkItemsNaiSelectItem - Select Item
> stkItemsNaiSetUpMenu - Set Up Menu
> stkItemsNaiProvideLocalInfo - Provide Local Info
> stkItemsNaiSetIdleModeText - Set Idle Mode Text
> stkItemsNaiOpenChannel - Open Channel
> stkItemsNaiCloseChannel - Close Channel
> stkItemsNaiReceiveData - Receive Data
> stkItemsNaiSendData - Send Data
> stkItemsNaiGetChannelStatus - Get Channel Status
> 
> Can you add these too along with the Mmi codes [bugzilla 879032]?
> 
> Nivi.

Sure. I'll add them to bug 879032.
Flags: needinfo?(ferjmoreno)
Actually, can just these strings be added along with the Gaia patch for this bug? It looks like the strings need to be added to the settings app, not the dialer one as in bug 879032.
Flags: needinfo?(frsela)
Created attachment 767607 [details] [diff] [review]
Nai localized strings
Attachment #767607 - Flags: feedback?(nsarkar)
Flags: needinfo?(frsela)
Comment on attachment 761339 [details]
Adding STK next action indicator support

Rebased and with localized strings.
Hi Fabien,

Could you please help us with the review?. Thanks!
Flags: needinfo?(kaze)
Comment on attachment 761339 [details]
Adding STK next action indicator support

Looks OK to me. Note that it would be better to use the localize() helper rather than doing “.textContent = _(id)”.
Attachment #761339 - Flags: review?(kaze) → review+
Kaze, thanks for the suggestion. I'll fix the nit asap, but landing since it's needed in leo.

Landed: https://github.com/mozilla-b2g/gaia/commit/895b29720949517187f0e8451fa205c6c4b5b232
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Hi John,

Could you please help us on uplifting this patch to V1-train?, we need to unblock STK/ICC testing on V1-train. Thanks!
Flags: needinfo?(kaze) → needinfo?(jhford)
Uplifted 895b29720949517187f0e8451fa205c6c4b5b232 to:
v1-train: ec6d94cc150d4ebc44fab47faaa856364b8f83cf
status-b2g18: --- → fixed
v1.1.0hd: ec6d94cc150d4ebc44fab47faaa856364b8f83cf
status-b2g-v1.1hd: --- → fixed
Flags: needinfo?(jhford)

Updated

5 years ago
Whiteboard: QARegressExclude

Updated

5 years ago
Flags: needinfo?(nsarkar)

Updated

5 years ago
Attachment #767607 - Flags: feedback?(nsarkar) → feedback+
You need to log in before you can comment on or make changes to this bug.