Fixed-width text parts of PDF document take very long to render anything

RESOLVED INVALID

Status

()

Firefox
PDF Viewer
P4
normal
RESOLVED INVALID
5 years ago
5 years ago

People

(Reporter: bjacob, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [pdfjs-c-performance], URL)

Testcase:

  http://www.intel.com/content/dam/www/public/us/en/documents/application-notes/processor-identification-cpuid-instruction-note.pdf

Go to page 117 (which the document itself calls page 119). The top of this page says "Program Examples" followed by "Example 10-4 [...]".

The rest of this page is a fixed-width code sample. It doesn't render at all for at least several seconds here in PDF.js, which made me believe that it just wouldn't render --- until I came back to that tab afterwards.
What version of Firefox are you using? The pdf page is very fast for me on OSX and windows.
Flags: needinfo?(bjacob)
Priority: -- → P4
Whiteboard: [pdfjs-c-performance]
(Reporter)

Comment 2

5 years ago
I am on Linux x86-64 (see bug metadata).
Flags: needinfo?(bjacob)
I see that. "What version of Firefox are you using?"
Flags: needinfo?(bjacob)
(Reporter)

Comment 4

5 years ago
This was also caused by my using Skia canvas. Reverting to Cairo (default) made it work.

I am on 24.0a1 btw.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Flags: needinfo?(bjacob)
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.