[B2G][Gallery] Video recording is not appearing in the Gallery app

RESOLVED DUPLICATE of bug 873971

Status

RESOLVED DUPLICATE of bug 873971
5 years ago
5 years ago

People

(Reporter: carlosmartinez, Assigned: johnhu)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(blocking-b2g:leo+)

Details

Description: After recording a video the video does NOT appear in the Gallery.

Repro:
1) Install (Gecko-ada3b96.Gaia-c51082d) unagi build
2) launch camera, and pick video recording.
3) Record a video.
3) stop the video recording, and launch gallery app

Expected:
video recording appears in gallery.

actual:
video recording does NOT appear in gallery, even after rebooting the Unagi.

NOTES:

The video DOES appear if User opens the video icon.

Unagi build: 20130521061744
Gecko-ada3b96
Gaia-c51082d
blocking-b2g: --- → leo?
Keywords: regression
blocking-b2g: leo? → leo+
Work for me on unagi @0531-b2g18(gecko:4f318822e72c) nightly build.
Works for me on Inari 20130603070207 nightly build.
Keywords: qawanted

Comment 3

5 years ago
Works for me and unable to repro issue on 

Unagi Build ID: 20130604070205
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/997cdbf5d012
Gaia: 5534304aee934055f08f21ce93261ba2a596516a
Keywords: qawanted
Assignee: nobody → johu
I got reproduced it with gaia v1-train commit c51082d92f18c4c7cdbc4f96c977be735500562a.

I thought this bug might be fixed by other bug fix.

I will continue to find out the reason...
This bug is caused by Camera app. While made a video recording, Camera app should generate a preview image for this video. But in this version(c51082d92f18c4c7cdbc4f96c977be735500562a), Camera app doesn't do it. And Gallery app uses this preview image to scan video. That's why we can't find the new video in Gallery app.

After some searching, I found there is a bug 873971 related to this one. It says video thumbnail can't be generated because of absolute path and relative path. Its patch is uplifted at 2013-05-28. I had applied this patch to c51082d92f18c4c7cdbc4f96c977be735500562a. Camera App generates preview image and Gallery app shows video.

Carlos, 

Would you mind to give latest version a try with the same STR??? If it works, let us mark this bug as duplicate of bug 873971.
Flags: needinfo?(carlos.martinez)
Is working fine with Gecko-d96f540.Gaia-ed5cee0 from v1-train in unagi device and is working fine, I will mark this one as a duplicate of bug 873971.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Flags: needinfo?(carlos.martinez)
Resolution: --- → DUPLICATE
Duplicate of bug: 873971
You need to log in before you can comment on or make changes to this bug.