Installer uses wrong font for directory name

RESOLVED WORKSFORME

Status

SeaMonkey
Installer
--
minor
RESOLVED WORKSFORME
17 years ago
9 years ago

People

(Reporter: Matthew Hornyak, Unassigned)

Tracking

({access})

Trunk
x86
Windows 2000
access

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 5.0)
BuildID:    2001062204

When the installer reaches the directory name page of the installer wizard, it 
uses my dialog box font, which is too large for the allotted space.

Either a smaller font should be used (such as hardcoding MS Sans Serif) or the 
space should be adjusted according to how large the font is.

Reproducible: Always
Steps to Reproduce:
1. Using the Control Panel, set your message box font to Gill Sans 24 (or 
another PostScript font with a large size)
2. Launch the installer
3. Go forward to the choose directory page

Actual Results:  Most of the text for the directory name was truncated

Expected Results:  I could view at least all of any character printed, followed 
by an ellipse indicating an abbreviated directory name
(Reporter)

Comment 1

17 years ago
Created attachment 39813 [details]
Installer with corrupted display

Comment 2

17 years ago
Ying, can you take a look at this?
Assignee: ssu → yxia

Comment 3

17 years ago
Well, we can not meet everything in the current installer. For the user-input 
fields, we had to pick a system font to allow Japanese user to type in Japanese 
characters, for example, the folder names. See bug 69445, it was more serious 
bug. Now we are using the system Message Dialog font for it. If user set their 
Message Dialog font too big, 24 this case, our installer dialog won't fit. 
Before I made my patch for bug 69445, I checked it already, many softwares have 
similar problems for the too-big font setting. We may need to consider 
everything in the future installer.

Comment 4

17 years ago
Ying, can't we, after getting the system font, set the size just for the purpose 
of the installer?  Then reset it back to the original size after getting the 
system font?
(Reporter)

Comment 5

17 years ago
for what it's worth, Mozilla is the only app I experience this in (both the 
Installer and the app itself), out of all the apps I use on my computer, so a 
workaround shouldn't be too difficult...

Comment 6

17 years ago
Yes, Sean, we can force the font to something, like 8, but you know, different 
systems have different default system size, for example, 8 for English, 9 for 
Japanese. If we force it to 8, the Japanese characters will looks little ugly. I 
wonder QA may bug us later if we do so.
(Reporter)

Comment 7

17 years ago
May I recommend: 

1) Use the menu font instead of the message box font - it's likely to be smaller
2) I'm pretty certain there's a Windows API function which will allow you to 
determine the dimensions of the text before you display it... perhaps run the 
text through this function?


Comment 8

16 years ago
*** Bug 95995 has been marked as a duplicate of this bug. ***
Confirming and marking NEW.

PS Greets to hablack (I also went to Tech).
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 10

16 years ago
Sean, do you mind if I reassign this bug to you? I think you are the right 
person to decide how we do it properly. Thanks.

Comment 11

16 years ago
would someone mind adding the access keyword to this bug?  Probably should be
mozilla/netscape 1.0 also.
Adding keywords per Hal's request.

PS VT greets! (I'm a CS graduate 2000)
Keywords: access, mozilla1.0

Comment 13

15 years ago
*** Bug 170110 has been marked as a duplicate of this bug. ***

Comment 14

15 years ago
*** Bug 197756 has been marked as a duplicate of this bug. ***
Product: Browser → Seamonkey

Updated

12 years ago
QA Contact: bugzilla → general
Assignee: yinglinxia → nobody
Seamonkey and Firefox are using a new NSIS based installer. resolving this old bug, please reopen if you still get this with the new installer
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.