Scrollbars/frames jiggle/resize in some cases in DOM Inspector

VERIFIED FIXED

Status

()

VERIFIED FIXED
6 years ago
5 years ago

People

(Reporter: Gijs, Unassigned)

Tracking

Trunk
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(firefox21 unaffected, firefox22 unaffected, firefox23+ verified, firefox24+ verified, firefox-esr17 unaffected)

Details

(Whiteboard: [lion-scrollbars+])

Attachments

(1 attachment)

4.08 MB, video/quicktime
Details
(Reporter)

Description

6 years ago
Created attachment 752210 [details]
Screencast

Sorry for the rather imprecise summary; essentially in some cases when I open DOMI, select the CSS Rules view, and hover over the right frames, the frames resize a little and scrollbars start (dis/re)appearing very very quickly.

I made a screencast to show what happens, which I've added in the attachment.
(Reporter)

Comment 1

6 years ago
Some more details: when the mouse moves, it seems the frequency of updating is delayed. At no point in the screencast did I do any actual scrolling.
Possibly related to bug 870917
status-firefox21: --- → unaffected
status-firefox22: --- → unaffected
status-firefox23: --- → affected
status-firefox24: --- → affected
status-firefox-esr17: --- → unaffected
tracking-firefox23: --- → ?
Whiteboard: [lion-scrollbars+]
tracking-firefox23: ? → +
tracking-firefox24: --- → +
This may be a long-shot, but bug 865702 could be related to this. Especially bug 865702 comment 44 could explain why this bug is happening.
I agree bug 865702 might be related.

That bug's now fixed (or so we hope).  The fix didn't land in time for today's mozilla-central nightly, but it'll be in tomorrow's.  We should test with that to see if we can still reproduce this bug.
I can't seem to figure out how to open the DOMI from the screencast. Gijs, could you check with a recent nightly and report back if this problem still occurs? Bug 865702 may have fixed this. Bonus points if you can tell me how to open the DOMI myself. :-) Thanks!
Flags: needinfo?(gijskruitbosch+bugs)
(Reporter)

Comment 6

6 years ago
I'm a keyboard person, so to open DOMI I just use cmd+shift+i. You do need to install it first ( https://addons.mozilla.org/en-US/firefox/addon/dom-inspector-6622/ ). It also shows up in the Web Developer tools once installed.

But I can't reproduce this anymore, so I'm marking this as fixed by bug 865702. Thanks a lot for looking into this! :-)
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Flags: needinfo?(gijskruitbosch+bugs)
Resolution: --- → FIXED
(Reporter)

Comment 7

6 years ago
Checked on Aurora, fixed there too. :-)
status-firefox23: affected → fixed
status-firefox24: affected → fixed
(Reporter)

Comment 8

6 years ago
(In reply to :Gijs Kruitbosch from comment #6)
> It also shows up in the Web Developer tools once installed.
Uh, by which I mean, in the menus under Tools > Web Developer, not in the actual devtools toolbox.
(In reply to :Gijs Kruitbosch from comment #6)
> You do need to install it first

Heh, that explains a lot. :-)

> But I can't reproduce this anymore, so I'm marking this as fixed by bug
> 865702. Thanks a lot for looking into this! :-)

Thanks for verifying!
Keywords: verifyme
Not reproducing on FF 23 beta 10 (build ID: 20130729175331).
Marking as verified
status-firefox23: fixed → verified
Keywords: verifyme
QA Contact: cornel.ionce
Verified this issue on Firefox 24 beta 4 (build ID: 20130819170952) and not reproducing.
Status: RESOLVED → VERIFIED
status-firefox24: fixed → verified
You need to log in before you can comment on or make changes to this bug.