If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Strange flick-to-scroll behavior using a trackpad

RESOLVED WORKSFORME

Status

()

Firefox
Untriaged
RESOLVED WORKSFORME
4 years ago
4 years ago

People

(Reporter: beingalink, Unassigned)

Tracking

24 Branch
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [testday-20130816])

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:24.0) Gecko/20130521 Firefox/24.0 (Nightly/Aurora)
Build ID: 20130521031106

Steps to reproduce:

1) Load a new page so the position is at its top (not some remembered position).
2) Flick-tp-scroll to the top (even though the page is already at its top position).
3) Flick-to-scroll down


Actual results:

The page scrolls down a bit but stops early. Doing the flick-to-scroll down gesture again makes it work correctly.


Expected results:

The page should have scrolled down a lot more. It works correctly if you do the gesture again.
I'm trying this with inertial scrolling turned on in the OSX preferences (10.8.4), and then doing a two finger flick to scroll. Is that also what you're doing? I'm not seeing the same behavior that you describe.
Flags: needinfo?(beingalink)
Whiteboard: [testday-20130816]
(Reporter)

Comment 2

4 years ago
Not sure about inertial scrolling: Where do you enable that in the preferences? The behavior is definitely still reproducable for me. Yes, I'm using 2 finger flick to scroll.
Flags: needinfo?(beingalink)
(Reporter)

Comment 3

4 years ago
Since today's nightly (2013-08-22) I can't reproduce this behavior anymore. Seems like it got fixed with some other bug.
Probably due to the backout of bug 673875, which was prompted by bug 907275.
Blocks: 673875
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.