Closed Bug 874618 Opened 11 years ago Closed 11 years ago

video element ignores playbackRate when set to exactly 1

Categories

(Core :: Audio/Video, defect)

20 Branch
x86_64
Windows 7
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 825329

People

(Reporter: mozilla, Unassigned)

Details

Attachments

(1 file)

Attached file playbackrate.html
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:20.0) Gecko/20100101 Firefox/20.0 (Beta/Release)
Build ID: 20130409194949

Steps to reproduce:

1. Begin playing a <video>
2. video.playbackRate = 2.0 (or some other value != 1)
3. video.playbackRate = 1.0

See attached, which is a simple demo modified from this: http://www.w3.org/2010/05/video/mediaevents.html


Actual results:

Step 3 is ignored; the video is still playing at the previous rate.

However, setting the playbackRate to something other than exactly 1 (such as 1.00001) does work.


Expected results:

Playback rate resets to the original.
Confirmed on Firefox 22 beta 2, on Windows 7, 64 bits, User agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:22.0) Gecko/20100101 Firefox/22.0, Build ID: 20130521223249.

However, I can't reproduce this on latest Nightly 24.0, nor on Aurora 23.0:

- User agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:24.0) Gecko/20130524 Firefox/24.0, Build ID: 20130524050555.

- User agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:23.0) Gecko/20130523 Firefox/23.0, Build ID: 20130523004551.

Reporter, could you please install the latest Aurora and/or Nightly, and see if it works for you too, there?
Download Aurora here: http://www.mozilla.org/en-US/firefox/aurora/
Download latest Nightly here: http://nightly.mozilla.org/

Please share your results in a comment after you will have tested on these builds.
Thank you!
Component: Untriaged → Video/Audio
Flags: needinfo?(mozilla)
Product: Firefox → Core
Probably a duplicate of bug 825329.
I tried Aurora and latest Nightly following the links in comment #1 just a few minutes and and it's working for me on both of those, but not on latest stable release. Thanks!
Flags: needinfo?(mozilla)
Very well, then it's definitely the issue fixed in bug 825329, as stated in comment #2.
I'm closing this as duplicate, and you should see it fixed on Firefox 23 (or on Firefox 22 if that fix will be included also on the current beta).
Thanks for your report!
Status: UNCONFIRMED → RESOLVED
Closed: 11 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Creator:
Created:
Updated:
Size: