[stage][traceback] 500 Error: ValidationError: [u'type cannot validate [1L]']

VERIFIED FIXED

Status

Participation Infrastructure
Phonebook
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: mbrandt, Assigned: giorgos)

Tracking

Details

(URL)

(Reporter)

Description

5 years ago
Steps to reproduce:
1. goto https://mozillians.allizom.org/admin/api/apiapp/
2. Select either the 'comapp' user or 'mozapp' user

Traceback (most recent call last):

  File "/data/www/mozillians.allizom.org/mozillians/vendor/src/django/django/core/handlers/base.py", line 136, in get_response
    response = response.render()

  File "/data/www/mozillians.allizom.org/mozillians/vendor/src/django/django/template/response.py", line 104, in render
    self._set_content(self.rendered_content)

  File "/data/www/mozillians.allizom.org/mozillians/vendor/src/django/django/template/response.py", line 81, in rendered_content
    content = template.render(context)

  File "/data/www/mozillians.allizom.org/mozillians/vendor/src/django/django/template/base.py", line 140, in render
    return self._render(context)

  File "/usr/lib64/python2.6/site-packages/newrelic-1.10.2.38/newrelic/api/object_wrapper.py", line 220, in __call__
    self._nr_instance, args, kwargs)

  File "/usr/lib64/python2.6/site-packages/newrelic-1.10.2.38/newrelic/api/function_trace.py", line 82, in dynamic_wrapper
    return wrapped(*args, **kwargs)

  File "/data/www/mozillians.allizom.org/mozillians/vendor/src/django/django/template/base.py", line 134, in _render
    return self.nodelist.render(context)

  File "/data/www/mozillians.allizom.org/mozillians/vendor/src/django/django/template/base.py", line 823, in render
    bit = self.render_node(node, context)

  File "/data/www/mozillians.allizom.org/mozillians/vendor/src/django/django/template/base.py", line 837, in render_node
    return node.render(context)

  File "/data/www/mozillians.allizom.org/mozillians/vendor/src/django/django/template/loader_tags.py", line 123, in render
    return compiled_parent._render(context)

  File "/usr/lib64/python2.6/site-packages/newrelic-1.10.2.38/newrelic/api/object_wrapper.py", line 220, in __call__
    self._nr_instance, args, kwargs)

  File "/usr/lib64/python2.6/site-packages/newrelic-1.10.2.38/newrelic/api/function_trace.py", line 82, in dynamic_wrapper
    return wrapped(*args, **kwargs)

  File "/data/www/mozillians.allizom.org/mozillians/vendor/src/django/django/template/base.py", line 134, in _render
    return self.nodelist.render(context)

  File "/data/www/mozillians.allizom.org/mozillians/vendor/src/django/django/template/base.py", line 823, in render
    bit = self.render_node(node, context)

  File "/data/www/mozillians.allizom.org/mozillians/vendor/src/django/django/template/base.py", line 837, in render_node
    return node.render(context)

  File "/data/www/mozillians.allizom.org/mozillians/vendor/src/django/django/template/loader_tags.py", line 123, in render
    return compiled_parent._render(context)

  File "/usr/lib64/python2.6/site-packages/newrelic-1.10.2.38/newrelic/api/object_wrapper.py", line 220, in __call__
    self._nr_instance, args, kwargs)

  File "/usr/lib64/python2.6/site-packages/newrelic-1.10.2.38/newrelic/api/function_trace.py", line 82, in dynamic_wrapper
    return wrapped(*args, **kwargs)

  File "/data/www/mozillians.allizom.org/mozillians/vendor/src/django/django/template/base.py", line 134, in _render
    return self.nodelist.render(context)

  File "/data/www/mozillians.allizom.org/mozillians/vendor/src/django/django/template/base.py", line 823, in render
    bit = self.render_node(node, context)

  File "/data/www/mozillians.allizom.org/mozillians/vendor/src/django/django/template/base.py", line 837, in render_node
    return node.render(context)

  File "/usr/lib64/python2.6/site-packages/newrelic-1.10.2.38/newrelic/api/object_wrapper.py", line 220, in __call__
    self._nr_instance, args, kwargs)

  File "/usr/lib64/python2.6/site-packages/newrelic-1.10.2.38/newrelic/hooks/framework_django.py", line 674, in wrapper
    return wrapped(*args, **kwargs)

  File "/data/www/mozillians.allizom.org/mozillians/vendor/src/django/django/template/loader_tags.py", line 62, in render
    result = block.nodelist.render(context)

  File "/data/www/mozillians.allizom.org/mozillians/vendor/src/django/django/template/base.py", line 823, in render
    bit = self.render_node(node, context)

  File "/data/www/mozillians.allizom.org/mozillians/vendor/src/django/django/template/base.py", line 837, in render_node
    return node.render(context)

  File "/usr/lib64/python2.6/site-packages/newrelic-1.10.2.38/newrelic/api/object_wrapper.py", line 220, in __call__
    self._nr_instance, args, kwargs)

  File "/usr/lib64/python2.6/site-packages/newrelic-1.10.2.38/newrelic/hooks/framework_django.py", line 674, in wrapper
    return wrapped(*args, **kwargs)

  File "/data/www/mozillians.allizom.org/mozillians/vendor/src/django/django/template/loader_tags.py", line 62, in render
    result = block.nodelist.render(context)

  File "/data/www/mozillians.allizom.org/mozillians/vendor/src/django/django/template/base.py", line 823, in render
    bit = self.render_node(node, context)

  File "/data/www/mozillians.allizom.org/mozillians/vendor/src/django/django/template/base.py", line 837, in render_node
    return node.render(context)

  File "/data/www/mozillians.allizom.org/mozillians/vendor/src/django/django/template/defaulttags.py", line 192, in render
    nodelist.append(node.render(context))

  File "/data/www/mozillians.allizom.org/mozillians/vendor/src/django/django/template/loader_tags.py", line 155, in render
    return self.render_template(self.template, context)

  File "/data/www/mozillians.allizom.org/mozillians/vendor/src/django/django/template/loader_tags.py", line 137, in render_template
    output = template.render(context)

  File "/data/www/mozillians.allizom.org/mozillians/vendor/src/django/django/template/base.py", line 140, in render
    return self._render(context)

  File "/usr/lib64/python2.6/site-packages/newrelic-1.10.2.38/newrelic/api/object_wrapper.py", line 220, in __call__
    self._nr_instance, args, kwargs)

  File "/usr/lib64/python2.6/site-packages/newrelic-1.10.2.38/newrelic/api/function_trace.py", line 82, in dynamic_wrapper
    return wrapped(*args, **kwargs)

  File "/data/www/mozillians.allizom.org/mozillians/vendor/src/django/django/template/base.py", line 134, in _render
    return self.nodelist.render(context)

  File "/data/www/mozillians.allizom.org/mozillians/vendor/src/django/django/template/base.py", line 823, in render
    bit = self.render_node(node, context)

  File "/data/www/mozillians.allizom.org/mozillians/vendor/src/django/django/template/base.py", line 837, in render_node
    return node.render(context)

  File "/data/www/mozillians.allizom.org/mozillians/vendor/src/django/django/template/defaulttags.py", line 192, in render
    nodelist.append(node.render(context))

  File "/data/www/mozillians.allizom.org/mozillians/vendor/src/django/django/template/defaulttags.py", line 192, in render
    nodelist.append(node.render(context))

  File "/data/www/mozillians.allizom.org/mozillians/vendor/src/django/django/template/defaulttags.py", line 281, in render
    return nodelist.render(context)

  File "/data/www/mozillians.allizom.org/mozillians/vendor/src/django/django/template/base.py", line 823, in render
    bit = self.render_node(node, context)

  File "/data/www/mozillians.allizom.org/mozillians/vendor/src/django/django/template/base.py", line 837, in render_node
    return node.render(context)

  File "/data/www/mozillians.allizom.org/mozillians/vendor/src/django/django/template/defaulttags.py", line 281, in render
    return nodelist.render(context)

  File "/data/www/mozillians.allizom.org/mozillians/vendor/src/django/django/template/base.py", line 823, in render
    bit = self.render_node(node, context)

  File "/data/www/mozillians.allizom.org/mozillians/vendor/src/django/django/template/base.py", line 837, in render_node
    return node.render(context)

  File "/data/www/mozillians.allizom.org/mozillians/vendor/src/django/django/template/base.py", line 880, in render
    return _render_value_in_context(output, context)

  File "/data/www/mozillians.allizom.org/mozillians/vendor/src/django/django/template/base.py", line 858, in _render_value_in_context
    value = force_unicode(value)

  File "/data/www/mozillians.allizom.org/mozillians/vendor/src/django/django/utils/encoding.py", line 71, in force_unicode
    s = unicode(s)

  File "/data/www/mozillians.allizom.org/mozillians/vendor/src/django/django/forms/forms.py", line 411, in __unicode__
    return self.as_widget()

  File "/data/www/mozillians.allizom.org/mozillians/vendor/src/django/django/forms/forms.py", line 458, in as_widget
    return widget.render(name, self.value(), attrs=attrs)

  File "/data/www/mozillians.allizom.org/mozillians/vendor/src/django/django/contrib/admin/widgets.py", line 259, in render
    output = [self.widget.render(name, value, *args, **kwargs)]

  File "/data/www/mozillians.allizom.org/mozillians/vendor-local/src/django-autocomplete-light/autocomplete_light/widgets.py", line 97, in render
    self.autocomplete_name, values))

ValidationError: [u'type cannot validate [1L]']
(Assignee)

Comment 1

5 years ago
This was due to incomplete test data. Filling "fullname" field (which is required) for "testuser" fixed the problem.

Thanks for reporting this Matt!
Assignee: nobody → giorgos
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
(Reporter)

Comment 2

5 years ago
Hot stuff! Thanks Giorgos .. QA verified, stage is righteous.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.