Closed Bug 874686 Opened 9 years ago Closed 5 years ago

[Project] Open Web Apps on Android (Firefox Mobile Apps)

Categories

(Tracking :: User Story, defect)

x86
macOS
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: cgalimidi, Assigned: vkrishnamoorthy)

References

(Depends on 1 open bug)

Details

User Story

APK FACTORY
- A Cloud service to make APKs from Open Web Apps
1. Verify input is valid
2. Generate APK signing key for each developer*
3. Sign the APK

- Cache the APK for use at install time
- Create new APK signing keys for most developers
- Store and use legacy APK signing keys for Android-savvy developers

DOWNLOAD / INSTALL
- native flow, with standard install confirmation dialog
- dialog lists permissions requested by privileged apps
- user must enable “unknown sources”; Marketplace/Firefox can help explain/direct
- reinstall from same Marketplace will update existing app, but reinstall from different Marketplace may duplicate app
- TBD how to handle reinstall of app installed as bookmark

USE & MANAGE
- launch via native Home, All Apps, and Recents screens
- quit, switch, and manage apps via native interfaces
- app appears like native app in all Android interfaces
- runtime prompts to access privileged APIs, à la FxOS
- TBD crash reporting and permissions management

UPDATE & REMOVE
- runtime will periodically check for and download updates
- should be similar to native update
- native remove flow
- if user removes Firefox, app prompts user to reinstall it
- TBD persist app data after Firefox removal

Attachments

(1 file)

+++ This bug was initially created as a clone of Bug #832525 +++

Master tracker for the Apps for Android program 
Phase 2 of the Firefox Mobile Apps Delivery

including but not limited to:
- "native" apps experience (or other methods of FFx App Management on Android)
- payments processor integration
No longer depends on: 832525, 832534, 835405, 839382, 862004, 862157, 862014
Vishy - 
Is it too early to add themes / epics for the phase 2 of the program?
It's likely way early for user stories... but we can probably put the themes in.
Assignee: nobody → vkrishnamoorthy
Depends on: 888391
Depends on: 835405
Depends on: 813753, 813749
Depends on: 813756
Depends on: 832534
No longer depends on: 813756
Depends on: 862157
No longer depends on: 813753
No longer depends on: 813749
Depends on: 896003
No longer depends on: 888391
No longer depends on: 835405
Depends on: 840190
No longer depends on: 840190
Depends on: 840190
No longer depends on: 832534
Summary: [Project] Firefox Mobile Apps Ph 2 → [Project] Open Web Apps on Android (Firefox Mobile Apps)
User Story: (updated)
Depends on: 888391
Depends on: 929382
Depends on: 930389
Depends on: 941926
Depends on: 945007
Depends on: 958329
Duplicate of this bug: 896003
Depends on: 936667
Depends on: 964394
Depends on: 965464
Depends on: 968380
Depends on: 1031038
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.