Selecting rating doesn't auto-align the review form

RESOLVED WONTFIX

Status

P5
normal
RESOLVED WONTFIX
6 years ago
6 years ago

People

(Reporter: krupa.mozbugs, Assigned: spasovski)

Tracking

({regression})

regression
Points:
---

Details

(Whiteboard: [fireplace] p=1)

(Reporter)

Description

6 years ago
steps to reproduce:
1. Launch marketplace-dev app on your Firefox OS phone
2. Navigate to the details page for any app
3. Click on the "Write a review" form
4. Select rating

expected behavior:
The form moves up to bring focus to the review comment field

observed behavior:
Selecting rating doesn't auto-align the review form
Testing this on Unagi it appears to work, but intermittently
Target Milestone: 2013-05-23 → ---
(Assignee)

Comment 2

6 years ago
This is inherently a platform bug since the textarea's `focus` handler is not firing at all and can be made to fire inconsistently by wrapping it in a `setTimeout` so that we wait for the keyboard to shrink the window. I am tempted to WONTFIX but I'll gladly consider further input.

Here's the commit for my version of the solution:

https://github.com/spasovski/fireplace/commit/4709ebf
Whiteboard: [fireplace] p=1
Priority: -- → P5
Yeah, this is a platform timing bug.
WONTFIXing since there's nothing we can do about it (if it's not handling events, we can't fire the events harder). This should fix itself in newer versions of FXOS as they bring it up to parity with FX for Android. Have another look around B2G 1.1 or 1.2.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.