Hitting < from review form loads the reviews listing page when submission fails

RESOLVED WORKSFORME

Status

Marketplace
Consumer Pages
P4
normal
RESOLVED WORKSFORME
5 years ago
5 years ago

People

(Reporter: krupa, Unassigned)

Tracking

Points:
---

Details

(Reporter)

Description

5 years ago
steps to reproduce:
1. Find a paid app with no reviews on your Firefox OS phone
2. Navigate to the details page for that app
3. Click on the 'Write a review' form
4. Select a rating and add a review comment; submit the form
5. For submission fails
6. Hit the < button

expected behavior:
User returns to the details page

observed behavior:
User ends up in an empty reviews listing page

Comment 1

5 years ago
This is by design, because if we didn't do this (and you were deep-linked) you'd end up on the homepage. Do you prefer that behaviour instead?
Priority: -- → P4
Flags: needinfo?(krupa.mozbugs)
(Reporter)

Comment 2

5 years ago
(In reply to Matt Basta [:basta] from comment #1)
> This is by design, because if we didn't do this (and you were deep-linked)
> you'd end up on the homepage. Do you prefer that behaviour instead?

The current behavior is confusing to the user since they didn't visit the page from the reviews listing page. If we can't return them to the details page, let's at least not load a blank page. We can add the user message - "There are no reviews for this app yet."
Flags: needinfo?(krupa.mozbugs)

Comment 3

5 years ago
We currently say that there are no reviews. If you're hitting a completely empty page, then that's a separate issue.

Comment 4

5 years ago
There's a message that says, "This app has no reviews" and no completely blank page.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.