[camera] the pick activity should allow to accept or reject the photo before sending it to the caller

RESOLVED DUPLICATE of bug 870726

Status

Firefox OS
Gaia::Camera
RESOLVED DUPLICATE of bug 870726
5 years ago
5 years ago

People

(Reporter: julienw, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
STR:
* open SMS app
* write a new message
* click on the little "attach content" icon in the bottom left
* choose "photo"
* take a picture

Expected:
* as a user I should accept/reject the photo before sending it

Actual:
* the photo is sent to the Sms app as soon as it's taken

leo? because it's related to the MMS work.
(Reporter)

Comment 1

5 years ago
Asking UX input stamp from the firefox OS UX team.
Flags: needinfo?(firefoxos-ux-bugzilla)

Updated

5 years ago
Flags: needinfo?(firefoxos-ux-bugzilla) → needinfo?(rmacdonald)
Hi Julien...

Thanks for catching this one. Although I can't see the "attach content" icon in my release, the expected behaviour you've outlined is in line with our pattern document, located here - https://mozilla.box.com/s/ie6x8zgm8902dveyb5xf 

Page 6, "Picking images from gallery", shows the image preview on screen 4 of the intended flow. Subsequent pages show the flows for video and other content types.

I hope this answers your question. Please flag me if you have any additional questions or concerns. 

- Rob
Flags: needinfo?(rmacdonald)
(Reporter)

Comment 3

5 years ago
Rob> the "attach content" icon is only on master :)

thanks for the answer ! should this be in 1.1 or is it due for 1.2 ?
Flags: needinfo?(rmacdonald)
(In reply to Julien Wajsberg [:julienw] from comment #3)
> Rob> the "attach content" icon is only on master :)
> 
> thanks for the answer ! should this be in 1.1 or is it due for 1.2 ?

Thanks, Julien... 

The 1.1 / 1.2 question is likely one for the product team. I've flagged Sri as most of the pick activity involves media apps. Sri, please redirect the request if I have the wrong contact. 

- Rob
Flags: needinfo?(rmacdonald) → needinfo?(skasetti)
Current you *can* reject before sending:

1. long press on image and choose "view", "remove" or "replace".

2. you can not send the message.

I agree that an in-camera UI for "accept", "retake" or "cancel" would be ideal. However, that's not necessary for 1.1. Switching from leo? to koi?.
blocking-b2g: leo? → koi?
(Reporter)

Comment 6

5 years ago
Dietrich, "caller" meant "the caller app" here ;) it was not targeted to only MMS.

I've seen it's been implemented in Bug 870726 though.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 870726
(Reporter)

Updated

5 years ago
blocking-b2g: koi? → ---
tracking-b2g18: ? → ---
(Reporter)

Updated

5 years ago
Flags: needinfo?(skasetti)
You need to log in before you can comment on or make changes to this bug.