If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Pulse notifications on Linux contain a buildid/previous_buildid which are a day off

RESOLVED DUPLICATE of bug 858953

Status

Release Engineering
General Automation
RESOLVED DUPLICATE of bug 858953
4 years ago
4 years ago

People

(Reporter: whimboo, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [mozmill-test-failure])

(Reporter)

Description

4 years ago
As we have seen today, we get notifications lately (since May 21st) which contains some bogus build ids. In detail between the buildid and the previous_buildid we have 2 days even a build from a day before is available. This might have been caused by bug 874885?

May 21st:
"previous_buildid": "20130519004019"
"buildid": "20130521004018"

May 22nd:
"previous_buildid": "20130520004018"
"buildid": "20130522004016"

This totally breaks our update tests for daily builds because we check for the correct buildids.

The following notification we got via pulsebuildmonitor:

May 21st:
{"locale": "en-US", "testsurl": "http://ftp.mozilla.org/pub/mozilla.org/firefox/tinderbox-builds/mozilla-aurora-linux/1369122018/firefox-23.0a2.en-US.linux-i686.tests.zip", "previous_buildid": "20130519004019", "job_number": 1, "build_number": null, "builddate": 1369122018, "tags": ["nightly"], "platform": "linux", "version": null, "revision": "a0305227b47a76c188a8533734ece8a0064f926f", "status": 0, "buildtype": "opt", "product": "firefox", "slave": "bld-linux64-ix-033", "buildername": "Linux mozilla-aurora nightly", "buildid": "20130521004018", "timestamp": "2013-05-21T09:37:26Z", "key": "build.mozilla-aurora-linux-nightly.1.log_uploaded", "logurl": "http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2013/05/2013-05-21-00-40-18-mozilla-aurora/mozilla-aurora-linux-nightly-bm57-build1-build1.txt.gz", "tree": "mozilla-aurora", "buildurl": "http://ftp.mozilla.org/pub/mozilla.org/firefox/tinderbox-builds/mozilla-aurora-linux/1369122018/firefox-23.0a2.en-US.linux-i686.tar.bz2", "release": null}

May 22nd:
{"locale": "en-US", "testsurl": "http://ftp.mozilla.org/pub/mozilla.org/firefox/tinderbox-builds/mozilla-aurora-linux/1369208416/firefox-23.0a2.en-US.linux-i686.tests.zip", "previous_buildid": "20130520004018", "job_number": 2, "build_number": null, "builddate": 1369208416, "tags": ["nightly"], "platform": "linux", "version": null, "revision": "10738444bf15b09de4c85d6594f4b56aab4ad520", "status": 0, "buildtype": "opt", "product": "firefox", "slave": "bld-linux64-ix-029", "buildername": "Linux mozilla-aurora nightly", "buildid": "20130522004016", "timestamp": "2013-05-22T09:49:09Z", "key": "build.mozilla-aurora-linux-nightly.2.log_uploaded", "logurl": "http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2013/05/2013-05-22-00-40-16-mozilla-aurora/mozilla-aurora-linux-nightly-bm61-build1-build2.txt.gz", "tree": "mozilla-aurora", "buildurl": "http://ftp.mozilla.org/pub/mozilla.org/firefox/tinderbox-builds/mozilla-aurora-linux/1369208416/firefox-23.0a2.en-US.linux-i686.tar.bz2", "release": null}
(Assignee)

Updated

4 years ago
Product: mozilla.org → Release Engineering
(Reporter)

Comment 1

4 years ago
I'm fairly sure that this was the similar underlying cause as bug 858953.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 858953
(Reporter)

Updated

4 years ago
Whiteboard: [mozmill-test-failure][qa-automation-blocked] → [mozmill-test-failure]
You need to log in before you can comment on or make changes to this bug.