Last Comment Bug 874896 - New TB Toolbar icon polish
: New TB Toolbar icon polish
Status: RESOLVED FIXED
: regression
Product: Thunderbird
Classification: Client Software
Component: Theme (show other bugs)
: 23 Branch
: All Mac OS X
: -- trivial (vote)
: Thunderbird 24.0
Assigned To: Josiah Bruner [:JosiahOne] (needinfo for responses)
:
Mentors:
Depends on:
Blocks: 861867
  Show dependency treegraph
 
Reported: 2013-05-22 07:43 PDT by Josiah Bruner [:JosiahOne] (needinfo for responses)
Modified: 2013-06-25 05:19 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
Patch. (139.71 KB, patch)
2013-05-22 11:02 PDT, Josiah Bruner [:JosiahOne] (needinfo for responses)
richard.marti: review+
richard.marti: ui‑review+
Details | Diff | Splinter Review
Patch with PNG optimized images (92.66 KB, patch)
2013-05-22 12:37 PDT, Richard Marti (:Paenglab)
josiah: review+
josiah: ui‑review+
Details | Diff | Splinter Review

Description Josiah Bruner [:JosiahOne] (needinfo for responses) 2013-05-22 07:43:15 PDT
Some of the new icons appear to have some imperfections. For example, the contacts button. It has a few extra pixels that were not fully erased, and the active state creates a slight smudge on the left side.

This bug is for fixing all those little details.
Comment 1 Josiah Bruner [:JosiahOne] (needinfo for responses) 2013-05-22 11:02:53 PDT
Created attachment 752850 [details] [diff] [review]
Patch.

Patch polishes up the toolbar icons.

Giving myself review+ since it's just an image change. Richard has ui-review.
Comment 2 Richard Marti (:Paenglab) 2013-05-22 12:32:07 PDT
Comment on attachment 752850 [details] [diff] [review]
Patch.

Yes where were some pixels left in the old images.

ui-r+

I plussed also the r because you minussed it :)
Comment 3 Richard Marti (:Paenglab) 2013-05-22 12:37:09 PDT
Created attachment 752895 [details] [diff] [review]
Patch with PNG optimized images

I run your images through a PNG optimizer. This saves some bytes. The patch is now about 93k and your original is about 140k. After you have checked this images you can also use this patch for check-in if you like.
Comment 4 Josiah Bruner [:JosiahOne] (needinfo for responses) 2013-05-22 13:31:16 PDT
Comment on attachment 752895 [details] [diff] [review]
Patch with PNG optimized images

Looks good to me. Let's land this one.
Comment 5 Ryan VanderMeulen [:RyanVM] 2013-05-28 10:17:14 PDT
https://hg.mozilla.org/comm-central/rev/27a08233b9ac

Note You need to log in before you can comment on or make changes to this bug.