No Aurora23.0a2 32bit autoupdate since 20/May/2013 on Linux

VERIFIED WORKSFORME

Status

VERIFIED WORKSFORME
6 years ago
5 years ago

People

(Reporter: alice0775, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [mozmill-test-failure][qa-automation-blocked])

(Reporter)

Description

6 years ago
Build Identifier:
http://hg.mozilla.org/releases/mozilla-aurora/rev/52d3f8780c6d
Mozilla/5.0 (X11; Linux i686; rv:23.0) Gecko/20130520 Firefox/23.0 ID:20130520004018

Steps To Reproduce:
1. Install old Aurora build
   ex http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2013-04-21-00-40-14-mozilla-aurora/firefox-22.0a2.en-US.linux-i686.tar.bz2
2. Start firefox
3. Help > About Aurora
4. "Check For Update"


Actual Results:
No Aurora23.0a2 32bit autoupdate since 20/May/2013

Expected Results:
Aurora23.0a2 32bit autoupdate on 22/May/2013 should available
Something odd happened here. Working forwards in time, everything in PDT:

Normal nightly:
Start	Sun May 19 00:40:21 2013
got_revision	        2238b2e42482    (Sat May 18 03:23:01 2013)
previous_buildid	20130518004019
buildid	                20130519004019

52d3f8780c6d landed at Sun May 19 00:03:31 2013 -0700, should have trigged a nightly just after midnight on the 20th but didn't.

Stuff landing on the 20th leads to a normal nightly:
Start	Tue May 21 00:40:36 2013
got_revision	        a0305227b47a    (Mon May 20 05:25:31 2013)
previous_buildid	20130519004019
buildid	                20130521004018

This one is crazy, the buildID is from the 20th and the revision is old. It's like the buildrequest has been pending for ages then finally gets service. It wasn't forced by self-serve.
Start	Tue May 21 11:08:21 2013
got_revision	        52d3f8780c6d    (Sun May 19 00:03:31 2013)
previous_buildid	20130521004018
buildid	                20130520004018

Normal nightly:
Start	Wed May 22 00:51:18 2013
got_revision	        10738444bf15    (Tue May 21 05:53:27 2013)
previous_buildid	20130520004018
buildid	                20130522004016

This strange order leads to the update server offering the 20130520004018 nightly. This should correct itself after another nightly, but it would be good to understand what buildbot was doing. 52d3f8780c6d landed at almost the same time as we would have been scheduling a nightly, but we're looking for good revisions with compiles that worked.
Duplicate of this bug: 874885
Note, time the other way round here:

mysql> select br.id as brid, br.results, from_unixtime(br.submitted_at) as subm, from_unixtime(b.start_time) as start from builds as b, buildrequests as br where b.brid=br.id and br.buildername='Linux mozilla-aurora nightly' order by br.submitted_at desc limit 4;
+----------+---------+---------------------+---------------------+
| brid     | results | subm                | start               |
+----------+---------+---------------------+---------------------+
| 24507461 |       0 | 2013-05-22 00:40:17 | 2013-05-22 00:51:18 |
| 24455179 |       0 | 2013-05-21 00:40:19 | 2013-05-21 00:40:37 |
| 24406956 |       0 | 2013-05-20 00:40:19 | 2013-05-21 11:08:21 |
| 24387011 |       0 | 2013-05-19 00:40:20 | 2013-05-19 00:40:21 |
+----------+---------+---------------------+---------------------+
4 rows in set (0.01 sec)

Note the third 3 row is consistent with the earlier comments.
Whiteboard: [mozmill-test-failure][qa-automation-blocked]
[Intended audience: RelEng]

catlee says we sometimes get into a situation where a build finishes but the master fails to update the database (transient fault or so). Later some checking happens, it looks like the job never finished and it gets rerun. This should create a second row in the builds table for the buildrequest.  This hasn't happened in this case:

mysql> select * from builds where brid=24406956;
+----------+--------+----------+------------+-------------+
| id       | number | brid     | start_time | finish_time |
+----------+--------+----------+------------+-------------+
| 24714039 |      1 | 24406956 | 1369159701 |  1369167339 |
+----------+--------+----------+------------+-------------+
1 row in set (0.00 sec)

Unfortunately we don't have logs on the buildbot master to look for information any more (that's bug 856594).

Since Linux Aurora now updates to 20130523004551 (as we'd expect) I'm going to close this WFM and we can reopen if it happens again.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → INCOMPLETE
Resolution: INCOMPLETE → WORKSFORME
Product: mozilla.org → Release Engineering
You need to log in before you can comment on or make changes to this bug.