Closed Bug 875000 Opened 6 years ago Closed 6 years ago

Only attempt to tweak StrictMode on API 9+

Categories

(Firefox Health Report Graveyard :: Client: Android, defect)

ARM
Android
defect
Not set

Tracking

(firefox23 fixed, firefox24 fixed)

RESOLVED FIXED
Firefox 24
Tracking Status
firefox23 --- fixed
firefox24 --- fixed

People

(Reporter: rnewman, Assigned: rnewman)

References

Details

Attachments

(1 file, 1 obsolete file)

PROCESS-CRASH | java-exception | java.lang.NoClassDefFoundError: android.os.StrictModeat org.mozilla.gecko.SysInfo.getCPUCount(SysInfo.java:60)
https://hg.mozilla.org/integration/mozilla-inbound/rev/2610c01d749f
Assignee: nobody → rnewman
Status: NEW → ASSIGNED
Target Milestone: --- → Firefox 24
Blocks: 872383
https://hg.mozilla.org/mozilla-central/rev/2610c01d749f
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Attached patch Fix for uplift. (obsolete) — Splinter Review
[Approval Request Comment]
Bug caused by (feature/regressing bug #): 
  Bug 872383

User impact if declined: 
  Exceptions on API 8 devices.

Testing completed (on m-c, etc.): 
  Tests went green on m-c.

Risk to taking this patch (and alternatives if risky): 
  Very slim.

String or IDL/UUID changes made by this patch:
  None.
Attachment #754655 - Flags: review+
Attachment #754655 - Flags: approval-mozilla-aurora?
Attached patch Fix for uplift.Splinter Review
Just like the other one, only a raw-rev not HTML rev!
Attachment #754655 - Attachment is obsolete: true
Attachment #754655 - Flags: approval-mozilla-aurora?
Attachment #755434 - Flags: review+
Attachment #755434 - Flags: approval-mozilla-aurora?
Attachment #755434 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Product: Firefox Health Report → Firefox Health Report Graveyard
You need to log in before you can comment on or make changes to this bug.