modal-on-modal problems in mail import wizard

VERIFIED DUPLICATE of bug 22658

Status

()

Core
XUL
--
minor
VERIFIED DUPLICATE of bug 22658
17 years ago
17 years ago

People

(Reporter: Jesse Ruderman, Assigned: Dan M)

Tracking

Trunk
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
1. Open Mozilla.
2. Open Mozilla Mail.
3. Select File|Import so the Import Wizard appears
4. Select the 'Address Book' radio button, select Next
5. Select Eudora, select Next
6. A "Select Settings file" dialog appears, cancel out of this dialog.

Result: "back" button becomes disabled (bug 57854)

7. Cancel out of the wizard.

Result: the Mail window loses focus to whatever app had focus before it
(probably this bug report or the Mozilla browser window from step 1).

I'm not sure if this bug still happens if you go through with the importing
instead of cancelling.
(Assignee)

Comment 1

17 years ago
That's the famous Windows OS bug first noted in Mozilla in bug 22658. You can 
verify that it's an OS bug with other Windows apps if you can find one with such 
a bad UI that it stacks up modal dialogs (see my comments in that bug, 2000-08-
30). Despite that, I hacked around it (see the bug) but the hack was partially 
backed out because it caused much worse bug 54936.

The partial reversion allows Mozilla to correct the incorrect window activation f 
the third modal window was a XUL window, but to continue to stumble when it was 
some kind of system window, like the OS filepicker dialog. Which is what's 
happening here. It's a relatively minor and rare problem and repercussions from 
hacks are pretty nasty; I think we want to leave it lie.


*** This bug has been marked as a duplicate of 22658 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 2

17 years ago
hmmm.  verified.
Status: RESOLVED → VERIFIED
(Assignee)

Comment 3

17 years ago
(actually there is an open bug reminding me to fix the remainder of the annoying 
problems with stacked dependent windows. it's bug 74053, which this bug would 
more happily be a duplicate of. whatever.)
You need to log in before you can comment on or make changes to this bug.