Add remote debugger support to Marionette

RESOLVED DUPLICATE of bug 1100124

Status

P5
normal
RESOLVED DUPLICATE of bug 1100124
6 years ago
4 years ago

People

(Reporter: jgriffin, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
After bug 797529 lands, Marionette and the remote debugger will no longer be mutually exclusive.  At that point, it would be great to enable remote debugging of Marionette scripts, so that a developer debugging one could step through or pause such a script during execution.

It looks like the way to approach that would be to create a debugger actor for Marionette to use to execute scripts (maybe similar to what is being done for Scratchpad in bug 825039).  Panos, would that approach work for Marionette?

I think we'd need to keep the current evalInSandbox approach as well, for cases where the debugger isn't active (e.g., B2G).
I haven't looked into bug 797529 yet, but wouldn't just using the chrome debugging actor (and the Browser Debugger tool) work for your case? Bug 809561 has a similar goal for the xpcshell test harness and a bit more detail, and there may be bugs filed for mochitests as well.
(Reporter)

Comment 2

6 years ago
Cool, thanks, I haven't looked into it in any detail yet.  Marionette executes scripts in content as well as chrome; would the chrome debugging actor be usable for that?
Yes, the only scripts that are off-limits are the ones that run in the debugger server's compartment (server machinery and actors).
jgriffin is this still needed?
Flags: needinfo?(jgriffin)
(Reporter)

Comment 5

5 years ago
It would be nice, but would be pretty disruptive, probably, so I'd rank it as pretty low priority.
Flags: needinfo?(jgriffin)
Priority: -- → P5
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1100124
You need to log in before you can comment on or make changes to this bug.