Lower Case Letters Not Sorted/Alphabetized (bookmarks order is case-sensitive)

RESOLVED INVALID

Status

()

Firefox
Bookmarks & History
RESOLVED INVALID
5 years ago
5 years ago

People

(Reporter: 20ac93a2, Unassigned)

Tracking

21 Branch
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Created attachment 753046 [details]
bookmarks.jpg

User Agent: Mozilla/5.0 (Windows NT 6.1; rv:17.0) Gecko/20100101 Firefox/17.0 (Beta/Release)

Steps to reproduce:

As far back as I can rember FIrefox has never allowed for lower case letters to be sorted, alphabetized in order for the bookmarks.

A lower case letter should not matter, e still comes before P as an example and it should work this way when you have names that you've bookmarked from sites that use a lowercase letter.

Please look at the attached screen shot to see what I'm talking about. there is a bookmark with a lowercase e yet it sit at the bottom below all the other bookmarks and is not being order...

I truly hope Mozilla will fix this once and for all...

THANKS


Actual results:

Lowercase letters are not respected and placed in order...


Expected results:

Lowercase letters should be respected so they are sorted in order...
(Reporter)

Comment 1

5 years ago
I forgot the bug tracker picks up User Agent string, I've changed this and the user agent above is not correct.

I'm using at present 21.0 in Linux, but it doesn't matter it does the same thing in any Windows version...


THANKS

Updated

5 years ago
OS: Windows 7 → All
Version: unspecified → 21 Branch

Comment 2

5 years ago
Works for me with 2013-05-27-03-10-27-mozilla-central-firefox-24.0a1.en-US.linux-x86_64.

Did you do "Sort By Name" on the folder?
Component: Untriaged → Bookmarks & History

Comment 3

5 years ago
Also WFM with 2013-02-19-03-10-55-mozilla-central-firefox-21.0a1.en-US.linux-x86_64.

Updated

5 years ago
Summary: Lower Case Letters Not Sorted/Alphabetized → Lower Case Letters Not Sorted/Alphabetized (bookmarks order is case-sensitive)
(Reporter)

Comment 4

5 years ago
Yes I've tried Sort By Name....

As long as Mozilla has created Firefox for Linux, I've never seen it sort with lowercase letters...

I've always put up with it all those years figuring it's not such an issue, so I've always just made them Uppercase instead...

But no, I've never seen this work in all these years across many Linux Distros; Ubuntu, Mint, Fedora and few others too...

I was just running the latest version of Ubuntu and Mint on some other computers and it wasn't working on those and I'm submitting this report under Slacwkare...

So I"m really shocked to hear others have this working and I"d like to know why I've never been able too in all these years.


THANKS
Mozilla/5.0 (X11; Linux i686; rv:24.0) Gecko/20130528 Firefox/24.0

Works for me with Firefox 21 RC (buildID: 20130512144307) and latest Nightly (buildID: 20130528030942).
(Reporter)

Comment 6

5 years ago
These are all the Linux distros I've used in the past 5 years, so whatever version of Firefox would of been 5 years ago to this date.

Arch
Fedora
Mint
Slackware
Ubuntu

I'm only giving an example of just 5 years, but I've seen this problem for as long as Firefox has been in Linux...

On every Linux distro I mentioned above, all I ever did was start Firefox, then imported the bookmarks, then I opened Firefox and when to a bookmark folder, right clicked on it 'Sort by Name' and it does nothing. So what else am I suppose to do, I mean this is all there is to it and it doesn't work...

We're just talking right now, you're saying it's working for you and I'm saying I've never seen this work in Linux, so how are we going to troubleshoot this?

THANKS

Comment 7

5 years ago
What happens if you start Firefox in safe mode?  If that doesn't solve the problem, what happens if you test it with a new profile?  (Copy 'places.sqlite' from the old profile to the new one, but do not make ANY other changes.)
(Reporter)

Comment 8

5 years ago
I tried Safe Mode then I tested with a new profile, only copying the 'places.sqlite' and neither one worked...

Comment 9

5 years ago
No one can duplicate your problem, and I have no idea what you are doing differently.  I'll tell you what I did recently with another product when no one could duplicate my problem.  I recorded the desktop and posted the recording in a public place, such as YouTube.  Ubuntu provides a screen recorder that can be used for that purpose.  Keep the file and the recorded area small.
(Reporter)

Comment 10

5 years ago
I'm not doing anything out of the ordinary at all..

As example, I'll install Ubuntu, Mint, Fedora, Slackware, etc... Then as soon as I'm on the desktop I start Firefox, then I click on 'Bookmarks' - 'Show All Bookmarks', I click 'Import and Backup' then 'Import Bookmarks From HTML' and that's all I'm doing...

I'm talking about just importing my bookmarks on a clean install of an OS, running Firefox for the first time and importing...

How many ways are there to import bookmarks and do this? My understanding is this is it, only one way...

Also how could someone actually screw this up and break it on a clean install of an OS? I don't see how that's possible...

THANKS

Comment 11

5 years ago
Hi Dasfox,

Per my understanding, the bookmarks appear as per their added time order. 

To get a sorted list:
1. You could right click on the bookmarks folder in which you are currently in
2. Choose "Sort by name". This sorts both capital and small letters as you are expecting.

Comment 12

5 years ago
There's considerable more discussion here:  http://forums.mozillazine.org/viewtopic.php?f=9&t=2714303 .  No one can duplicate the behavior there.

Dasfox sent me a 'places.sqlite' file.  The initial order was indeed case-sensitive, but right clicking and sorting by name worked correctly on Linux and Windows, and changes were persistent.  Changes made by clicking on the 'Name' heading or the 'View' heading in the Library view were not persistent, which is consistent with bug 405108 and bug 405110.

The attachment 'bookmarks.jpg' seems consistent with bug 405108, and does not specifically show case-sensitivity.  However, in the support forum Dasfox reports "[in Library view] Clicked on Bookmarks - Clicked on the folder and then clicked 'Sort by Name' and the lowercase bookmark did not sort....", and "I'm not sure if I mentioned this, but if I go to; Show All Bookmarks. Click on the folder on the left, and go to View > Sort > Sort by name nothing happens..."
(Reporter)

Comment 13

5 years ago
Does Firefox require any particular dependency to make this work?

It's my understanding that Firefox does use a sqlite database, so all I assumed was that I needed sqlite installed? But would I also need mysql installed for this, or any other dependency?

I have deleted every Mozilla directory I could find in my $HOME path and that was ~/.mozilla & /.cache/mozilla, so after deleting both of these, I am now essentially starting it clean and like for the first time. 

Now I just start Firefox, make no changes to anything and simply go to two websites, make only two bookmarks, make one with lowercase letters, the other uppercase, and it doesn't sort...

So now I'm thinking I'm missing something in this Slackware installation causing Firefox to not work propertly?

THANKS
(Reporter)

Comment 14

5 years ago
Can a developer please tell me when we click on 'Sort By Name' what makes this step/process work, is it an external library, dependency, database, etc., or is it just code in Firefox that makes it work?


THANKS

Comment 15

5 years ago
No one has been able to duplicate this, even with the reporter's places file.

Comments can still be posted.  Feel free to reopen this if new evidence comes to light.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 16

5 years ago
Well maybe this is something specific to Slackware, so how many people running Slack have tried this?

Also I'm only running Openbox, so I'm not sure how Openbox as my DE could be an issue...

I've also asked several times and have not been able to get any clear answers to this question...

Does the sorting of bookmarks require any libraries, dependencies, database besides sqlite, etc...? Or is it just the code in Firefox that this works off of?

Also when I install Slackware I do an Expert install picking and choosing what I want to install, so maybe I could be missing something, that's why I've been asking if the sorting requires something...
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---

Comment 17

5 years ago
(In reply to dasfox from comment #16)
> Well maybe this is something specific to Slackware, so how many people
> running Slack have tried this?

But you said in Comment 6 that it didn't work either with Arch, Fedora, Mint, Slackware, Ubuntu, or as I recall, Windows.  But if it is a Slackware problem, you need to report it as a Slackware bug.
 
> Also I'm only running Openbox, so I'm not sure how Openbox as my DE could be
> an issue...

So try it with yet another desktop.


> Does the sorting of bookmarks require any libraries, dependencies, database
> besides sqlite, etc...? Or is it just the code in Firefox that this works
> off of?
> Also when I install Slackware I do an Expert install picking and choosing
> what I want to install, so maybe I could be missing something, that's why
> I've been asking if the sorting requires something...

If you install through the repositories of most distros, you we meet all the dependencies.  Maybe you should ask in the Slackware forum what happens if you have missing dependencies.  Most likely an error message.  If you install the Mozilla version, as has been suggested several times, that will automatically satisfy all dependencies.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago5 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 18

5 years ago
I said it wasn't working for me on those distros above, I never said Windows.

I later said on the Mozillazine forum that it didn't work if I used my bookmarks, but if I created them it worked, so I failed to see how just importing my bookmarks caused this not to work.

I've only been asking about a dependency as far as the bookmark sorting is concerned, nothing else. Does the process, or action of sorting require something to make this happen?

If I was missing something that Firefox required as a library, dependency etc, then it should complain about this if I run it from the CLI, but I do not see it giving me any warnings or messages about missing libraries, or dependencies at a terminal...

AGAIN I AM ONLY ASKING IF THE PROCESS OR ACTION OF SORTING REQUIRES ANYTHING TO MAKE IT WORK? WHEN AN END-USER CLICKS 'SORT BY NANME' WHAT MAKE THIS WORK?


THANKS
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---

Comment 19

5 years ago
Maybe it depends on something related to something like LC_COLLATE?
(Reporter)

Comment 20

5 years ago
Ok, I just downloaded today the Mozilla binary from mozilla.org; firefox-21.0.tar.bz2 and I opened the tar and ran Firefox from the command line as;

./firefox

Then all I did was import my bookmarks I exported out of the previous version that Pat from Slackware compiles from source and the bookmarks still do not sort in the Mozilla binary.

So now what are we talking about here when the binary from Mozilla won't sort the bookmarks for me?

THANKS

Comment 21

5 years ago
OK, perhaps some sort of localization thing, something to do with character sets and the way they are ordered.  Did anyone try to duplicate this with a profile you submitted?
(Reporter)

Comment 22

5 years ago
VanillaMozilla, if you are asking about a profile for the binary version I did not submit any.

Should I run the binary version again and then submit the places.sqlite and bookmarks.html?


THNAKS

Comment 23

5 years ago
As Aleksej says, it may be dependent on your locale's collating order. If you run this line in a console, what output do you get?

echo -e "a\nb\nc\nA\nB\nC" | sort

On my system it prints this:

a
A
b
B
c
C
(Reporter)

Comment 24

5 years ago
This is what I'm getting below;


$ echo -e "a\nb\nc\nA\nB\nC" | sort
    
A
B
C
a
b
c

And I was told if it is dependent on any language or collation settings, it would be those of your DE.

So I only run Openbox as my DE, just stand alone, so now I wonder if something in Openbox, or using Obconf has caused this issue...

Comment 25

5 years ago
So that proves that the problem is caused by your system's locale settings, because command-line sort also sorts in the 'wrong' order. 

In other words, it's not a bug in Firefox. Firefox just sorts the entries in the order that your system tells it to. Any program that does locale-aware sorting will be similarly affected. 

To fix it, you should change your system's locale to one that ignores letter case when sorting.

Running |locale| should show which one you're currently using, and running |locale -a| should show all available locales. The way to set it is usually distribution-specific though. For Slackware, see:

http://docs.slackware.com/slackware:localization

Comment 26

5 years ago
Try this:

1. Run locale -a to view the list of available locales on your system. The list should include "C", "POSIX" and some others (hopefully).

2. Now close Firefox and restart it using this command instead of ./firefox:

LC_COLLATE=[locale] ./firefox

Replace [locale] with one of the locales listed in step 1, but not "C" or "POSIX". For example, if "en_US.utf8" is listed, run this command:

LC_COLLATE=en_US.utf8 ./firefox

Does it work when you do that?
(Reporter)

Comment 27

5 years ago
Ok I never considered any of this since in the /etc/profile.d/lang.sh
this is what Slack uses by default and mentions;

# One side effect of the newer locales is that the sort order
# is no longer according to ASCII values, so the sort order will
# change in many places.  Since this isn't usually expected and
# can break scripts, we'll stick with traditional ASCII sorting.
# If you'd prefer the sort algorithm that goes with your $LANG
# setting, comment this out.


The problem for me is that I'm only running Openbox while most Slackware
users are using either KDE or Xfce as their DE. But they also are using
it with the same default setting of;
export LC_COLLATE=C

So does anyone know what KDE or Xfce are doing to that makes this work
in those DE, whereas a WindowManager like Openbox it's not?

I didn't think any DE would change this?

LC_COLLATE=en_US.utf8 ./firefox works...
(Reporter)

Comment 28

5 years ago
Sorry that entire line was suppose to be like this;

# One side effect of the newer locales is that the sort order
# is no longer according to ASCII values, so the sort order will
# change in many places.  Since this isn't usually expected and
# can break scripts, we'll stick with traditional ASCII sorting.
# If you'd prefer the sort algorithm that goes with your $LANG
# setting, comment this out.
export LC_COLLATE=C

Updated

5 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago5 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.