Send Message Progress-Bar (in the statusbar) should show "Progress" (and not just a barber pole)

VERIFIED FIXED in mozilla0.9.4

Status

MailNews Core
Composition
P3
normal
VERIFIED FIXED
17 years ago
10 years ago

People

(Reporter: Peter Lairo, Assigned: Jean-Francois Ducarroz)

Tracking

Trunk
mozilla0.9.4

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

17 years ago
Mozilla/5.0 (Windows; U; Win98; en-US; rv:0.9.1+) Gecko/20010622

Send Message Progress Bar should show "Progress" (and not just a barber pole).

This is particularly useful for messages with attachments.
(Reporter)

Updated

17 years ago
Keywords: mozilla0.9.2, nsCatFood, ui
ccing hwaara.  Hakan, isn't this a dup of one of your bugs?
Whiteboard: DUPEME

Comment 2

17 years ago
Nope. But it might be a dup of any of ducarroz's bugs.

-> Composition
Component: Mail Window Front End → Composition

Comment 3

17 years ago
this should be dup of bug 86393
(Reporter)

Comment 4

17 years ago
NO, not a dupe, because this bug means the progress bar in the *status bar* (and
not in the extra window, which would have made this bug a wontfix, not a dupe).
Sorry for not being more clear in the summary -> changing.
Summary: Send Message Progress Bar should show "Progress" (and not just a barber pole) → Send Message Progress-Bar (in the statusbar) should show "Progress" (and not just a barber pole)

Comment 5

17 years ago
*** This bug has been confirmed by popular vote. ***
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Updated

17 years ago
Keywords: mozilla0.9.2 → mozilla0.9.3
Whiteboard: DUPEME

Comment 6

17 years ago
adding keyword nsenterprise
Keywords: nsenterprise

Comment 7

17 years ago
reassigning to ducarroz.  I think this might be fixed.
Assignee: sspitzer → ducarroz
(Assignee)

Comment 8

17 years ago
during a send/save operation, the status bar show exactly the same status than
the send/save progress dialog. I don't understand why this bug get open! Peter,
can you explain exactly what's the problem. Thanks
(Reporter)

Comment 9

17 years ago
Progress-bar, as in: *a bar that increases in size* as more and more of the
message is transmitted.

Like this:
 10% #
 20% ##
 50% #####
100% ##########
Not like this:
////////////// (rotating stripes)
(Reporter)

Comment 10

17 years ago
BTW, I only care about the *statusbar*. I could care less about the unnecessary
and poor UI design decision of the "send progress dialog" (which should be
abolished anyways). :|
(Assignee)

Updated

17 years ago
Status: NEW → ASSIGNED
Whiteboard: Have fix
(Assignee)

Comment 11

17 years ago
Created attachment 44795 [details] [diff] [review]
Proposed fix, v1
(Assignee)

Updated

17 years ago
Whiteboard: Have fix → Have fix, need r & sr

Comment 12

17 years ago
Should we have a common function for the calculations of the progress-bar
status?. We seem to have similar code in lots of places throughout the product.
Other than that - r=varada
(Assignee)

Updated

17 years ago
Whiteboard: Have fix, need r & sr → Have fix, need sr
(Assignee)

Updated

17 years ago
Priority: -- → P3
Target Milestone: --- → mozilla0.9.4
+      var overallProgress = aCurTotalProgress;

why define this?  just use aCurTotalProgress in your function

+      if ( aMaxTotalProgress != "-1" ) 

is aMaxTotalProgress a string, or an int, or both?  do some callers call
onProgressChange() with a string and some with an int?

varada, that code is sprinkled all over, but mostly I've seen it in C++.  does
it exist anywhere else in JS?
(Assignee)

Comment 15

17 years ago
I copied this code from the progress dialog JS and modified it. The problem with
JS is that even if we try to put into a common file, JS will still have to
compile it each time we use it therefore they will be no speed gain but rather
even a degradation as JS need to open an extra file.
(Assignee)

Comment 16

17 years ago
Created attachment 45412 [details] [diff] [review]
proposed fix, v2

Comment 17

17 years ago
change to myself 
QA Contact: esther → sheelar
(Assignee)

Comment 18

17 years ago
Fixed and checked in
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED
Whiteboard: Have fix, need sr
(Reporter)

Comment 19

17 years ago
I sure hope this checkin fixes the *Statusbar* and not just that useless extra
"status window". ;)

Comment 20

17 years ago
verified, send progress in the status bar is same as the in the send progress dlg

2001-08-13-06 win98
2001-08-13-04 mac
2001-08-13-06 linux
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.