ff using deprecated Components object according to ff debugger

RESOLVED WORKSFORME

Status

()

Firefox
Developer Tools
RESOLVED WORKSFORME
5 years ago
5 years ago

People

(Reporter: Jim Michaels, Unassigned)

Tracking

20 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:20.0) Gecko/20100101 Firefox/20.0 (Beta/Release)
Build ID: 20130409194949

Steps to reproduce:

was debugging a web page in my own code with built-in debugger


Actual results:

got this message
[19:05:50.005] The Components object is deprecated. It will soon be removed. @ chrome://global/content/devtools/dbg-script-actors.js:1566
I have not gotten it again, do not know what caused it but apparently this seems to be an issue for mozilla (?) to solve - its your own browser code.


Expected results:

should not have gotten the error.
(Reporter)

Comment 1

5 years ago
http://jesusnjim.com/calculators/finances/calculator-with-estimator-to-save-up-for-item.html was the web page. the code has changed since then, I commented out some break; lines in atoi64.js so that the code would work.
Works for me (got no message) on Windows 7, 64 bits, with Firefox 22 beta 2, User agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:22.0) Gecko/20100101 Firefox/22.0, Build ID: 20130521223249.

Reporter, do you still see this message on Firefox 21.0 and/or on the Beta release, Firefox 22?
Component: Untriaged → Developer Tools
Flags: needinfo?(jmichae3)
(Reporter)

Comment 3

5 years ago
happened *once*. have no idea what caused it. seems to be unrepeatable since I don't know how to repro. did you look at the code in chrome://global/content/devtools/dbg-script-actors.js to see what any problem was?
Flags: needinfo?(jmichae3)
That warning used to appear whenever you inspected the global scope in the web console or debugger. Bug 790732 removed it from content, so I think that's what fixed it.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 5

5 years ago
cool.
You need to log in before you can comment on or make changes to this bug.