IMAP only, subfolders duplicated on 2nd launch of Messenger

VERIFIED FIXED in M9

Status

P3
normal
VERIFIED FIXED
20 years ago
14 years ago

People

(Reporter: nbaca, Assigned: Bienvenu)

Tracking

Trunk
All
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

20 years ago
Build 1999062208M8 for Win32/NT4, Linux/Redhat 5.2. The Mac build wasn't working
on 6/22 but duplicated the problem in the 1999061908M7 build.

Subfolders in an IMAP account can appear duplicated. POP accounts do not have
this problem.

Steps to Reproduce:
1. With 4.6 create a parent folder called "Folder1".
2. Under the parent folder create subfolders "FolderA", "FolderB" and "FolderC".
so the structure looks like this with each folder containing 1 message:

Folder1
  FolderA
  FolderB
  FolderC

3. Exit out of 4.6 and run "apprunner -mail"
4. Open Folder1 and the 3 subfolders appear as expected. Explorer
shows the msf files being created for the three subfolders. Notice the messages
are in the correct folder.
5. Exit the application and restart "apprunner -mail".
6. Open Folder1 and the 3 subfolders are duplicated. Each subfolder
includes the correct message. There are no extra msf files showing in
Explorer:

Folder1
  FolderA
  FolderB
  FolderC
  FolderA
  FolderB
  FolderC

7. Exit out and restart "apprunner -mail" and the subfolders are still
duplicated. Atleast they do not appear in triplicate.

8. If the parent folder is collapsed and expanded then the subfolders are
displayed normally and remain that way throughout rest of the mail session.

Note: Scurtis looked at the IMAP log to see if anything was unnecessarily
repeating at the time the apparent duplication took place. It wasn't.
(Reporter)

Updated

20 years ago
QA Contact: lchiang → scurtis

Updated

20 years ago
Assignee: phil → alecf
Target Milestone: M8

Comment 1

20 years ago
Reassign to alecf for M8. cc putterman.

Comment 2

20 years ago
hmm.. I think this is mscott's arena...but it might just be the tree.
scottip, have there been any changes to the tree widget that would cause this?
(you are pretty up to date on this stuff)

Comment 3

20 years ago
I don't think the tree widget would cause this, but I'll try to look into that.

Comment 4

20 years ago
The build date nbaca was using was 6/22 so it doesn't include the tree widget
landing. So I don't think the tree widget changes could be causing this.

Updated

20 years ago
Assignee: alecf → jefft

Comment 5

20 years ago
Reassigning to jefft because I think he's working on this.  This is all in IMAP
code.

I don't know why this only happens to the subfolders of a top level folder, but
this is what is happening.

The first time through GetTargets is asking you to create subfolders and so you
look on this disk and create my 3 folders.

Then when I double click on the folder with the subfolders,

NS_IMETHODIMP nsImapMailFolder::PossibleImapMailbox(
	nsIImapProtocol* aProtocol, mailbox_spec* aSpec)

gets called.  This also calls CreateSubfolders and readds the same three
folders.

Updated

20 years ago
Status: NEW → ASSIGNED

Comment 6

20 years ago
Accepting bug...
(Assignee)

Comment 7

20 years ago
I'm not seeing this - is it still happening?

Updated

20 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 20 years ago
Resolution: --- → WORKSFORME

Comment 8

20 years ago
This seems went away. Must be rdf problem. Marking it works for me.
(Reporter)

Comment 9

20 years ago
Build 1999070208M8: Win32/NT4

The same problem is occuring on my system. Using IMAP test accounts for qatest22
and qatest33.

Comment 10

20 years ago
Try to delete your old *.msf files and test on today's build if there is one.
Reopen the bug if you can still reproduce the problem. Thanks,
(Reporter)

Updated

20 years ago
Status: RESOLVED → REOPENED
(Reporter)

Comment 11

20 years ago
Build 1999070608M8: Win32/NT4

I deleted the msf files in the IMAP test accounts for qatest33 and qatest22.
Launched Messenger, opened the folders that include subfolders (A, B and C) and
it looks ok. Exited out of the apprunner.exe, restarted apprunner.exe, started
Messenger expanded the folders that include subfolders and now they appear
duplicated (A,B,C then A,B,C again).

Updated

20 years ago
Resolution: WORKSFORME → ---

Updated

20 years ago
Status: REOPENED → ASSIGNED
Target Milestone: M8 → M9

Comment 12

20 years ago
Moving to M9...
(Assignee)

Updated

20 years ago
Assignee: jefft → bienvenu
Status: ASSIGNED → NEW
QA Contact: scurtis → lchiang
(Assignee)

Comment 13

20 years ago
I'm taking this one - it's bugging me, and I think there's something weird going
on here.
(Assignee)

Updated

20 years ago
Status: NEW → RESOLVED
Last Resolved: 20 years ago20 years ago
Resolution: --- → FIXED
(Assignee)

Comment 14

20 years ago
this is fixed as of today by fixing the imap discovery code to try to find
children by uri in nsImapMailFolder.cpp

Updated

19 years ago
Status: RESOLVED → VERIFIED

Comment 15

19 years ago
verified fixed with builds 1999081608
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.