DocumentLocalized not rising in Chrome

RESOLVED WORKSFORME

Status

L20n
HTML Bindings
RESOLVED WORKSFORME
5 years ago
2 years ago

People

(Reporter: Silent Imp, Assigned: gandalf)

Tracking

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_8_3) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/27.0.1453.93 Safari/537.36

Steps to reproduce:

document.addEventListener('DocumentLocalized', function(){alert('l20n is ready');});



Actual results:

it work fine in FF, but don't work in Chrome


Expected results:

L20n must work in any browser
Component: General → HTML Bindings
(Assignee)

Updated

5 years ago
Assignee: nobody → gandalf
Target Milestone: --- → 1.0
(Assignee)

Comment 1

5 years ago
Created attachment 758734 [details] [diff] [review]
patch

The only bug I found in Chrome is that we use "const" in strict mode. I switched it to var, since const is not part of ECMA.

With this change I get an alert window.
Attachment #758734 - Flags: review?(stas)
Comment on attachment 758734 [details] [diff] [review]
patch

Review of attachment 758734 [details] [diff] [review]:
-----------------------------------------------------------------

Good catch. r=me.
Attachment #758734 - Flags: review?(stas) → review+
(Assignee)

Comment 4

5 years ago
Reporter, can you confirm that the code in question works in Chrome for you now?
Flags: needinfo?(thesilentimp)
(Assignee)

Comment 5

5 years ago
closing for now. If the bug still exists, please, reopen.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
(Assignee)

Comment 6

2 years ago
clearing NI
Flags: needinfo?(thesilentimp)
You need to log in before you can comment on or make changes to this bug.