Marketplace dev manifest file contains the name "Marketplace"

VERIFIED FIXED in 2013-05-30

Status

Marketplace
General
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: zac, Assigned: cvan)

Tracking

2013-05-30
Other
Gonk (Firefox OS)
Points:
---

Details

(Whiteboard: p=1)

(Reporter)

Description

5 years ago
Some time in the last 24 hrs or so the "name" field in the marketplace-dev manifest file change from "Marketplace Dev" to just "Marketplace".

This means when the dev app is installed on B2G it cannot be easily distinguished from the Production app.

This is also blocking all marketplace testing on B2G because the automation code relies on the "name" to distinguish between the two apps.

https://marketplace-dev.allizom.org/manifest.webapp
The reason it was changed was because we were testing installation on -dev. If the manifest in the package doesn't match the mini-manifest we get a MANIFEST_MISMATCH error and it won't install. It is more difficult to change the manifest in the zip so we changed the mini manifest instead.

If we want to keep the names different we'll need either distinct packages where we also update the package manifest, or something in our build steps to change the name depending on the target.

Comment 2

5 years ago
The new way to install marketplace-dev

1) install -dev certs (ask Krupa how)
2) uninstall your existing marketplace dev app (because we can't install two apps from the same origin)
3) open https://marketplace-dev.allizom.org/debug
4) click "install yulelog" button
5) open up the new Marketplace yulelog app
(Assignee)

Comment 3

5 years ago
Thanks, Rob. Yeah that's all correct. I need to write some automation script that generates a -dev and staging packaged app version which changes the names and signs the scripts. I can keep this bug open until I do that. But this is how it'll be for the next few days at least.
(Reporter)

Comment 4

5 years ago
Thanks Cvan, the steps in krupa's comment are a bit too tricky for automation so at least until we get marketplace-dev into Engineering builds by default your solution will be what we need to get unblocked.
(Assignee)

Updated

5 years ago
Assignee: nobody → cvan
Target Milestone: --- → 2013-05-30
Severity: blocker → normal
(Reporter)

Updated

5 years ago
Blocks: 873413
(Assignee)

Comment 5

5 years ago
https://github.com/mozilla/fireplace/commit/f048a79

Marketplace apps were added in bug 876963 comment 1:

Gaia will autoupdate from this app:
https://marketplace.firefox.com/app/marketplace/

We should not and cannot continue testing the Marketplace as an installable hosted app. So I've uploaded versions of the packaged Marketplace onto the Marketplace.

(1) Please uninstall any hosted versions of -dev, staging, prod on your devices.
(2) From within your browser, install the following packaged apps for -dev and staging, respectively:
    - https://marketplace-dev.allizom.org/app/marketplace/
    - https://marketplace.allizom.org/app/marketplace/
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Whiteboard: p=1

Comment 6

5 years ago
Note that you still need to have dev certs installed to be able to do this. I think the problem is resolved in an acceptable manner here. Please reopen if you disagree.
Status: RESOLVED → VERIFIED
(Assignee)

Updated

5 years ago
No longer blocks: 873413
(Reporter)

Comment 7

5 years ago
Somehow this is working fine without the certificates but that's good because it means automation's back on.
(Assignee)

Comment 8

5 years ago
Zac, I added back the name to the hosted manifest. We're no longer supporting the hosted manifest, so technically you can keep using it but in the future so that we're testing something that is identical to the app in production on the device, we'll want to be testing the -dev packaged app above.
You need to log in before you can comment on or make changes to this bug.